www.cendio.com

Bug 3983

Summary: vncconfig cannot set any parameters
Product: ThinLinc Reporter: Henrik Andersson <hean01@cendio.se>
Component: VSM AgentAssignee: Peter Åstrand <astrand@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 Keywords: hean01_tester
Version: 3.2.0   
Target Milestone: 4.1.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:
Bug Depends on:    
Bug Blocks: 4466    

Description From cendio 2011-09-06 14:10:47
sessionstart.py does start Xvnc with -desktop argument to set the desktop title
name to user@host which overrides the setting of title from the xstartup.d
script
for setting the title.

When trying to set a name using vncconfig which is used in the xstartup script
it fails, I also tested to remove the -desktop param from sessionstart.py but
this didnt solve the issue.
------- Comment #1 From cendio 2012-06-27 16:19:52 -------
The problem is not specific to the "desktop" parameter; I cannot set any param.
------- Comment #2 From cendio 2012-11-26 16:10:28 -------
With luck, this fixes the problem:

Revision: 5014
          http://tigervnc.svn.sourceforge.net/tigervnc/?rev=5014&view=rev
Author:   atkac
Date:     2012-11-26 12:01:42 +0000 (Mon, 26 Nov 2012)
Log Message:
-----------
Fix handling of whitelisted "vncconfig -set" parameters in Xvnc.
------- Comment #3 From cendio 2013-01-10 12:51:39 -------
(In reply to comment #2)
> With luck, this fixes the problem:
> 
> Revision: 5014
>           http://tigervnc.svn.sourceforge.net/tigervnc/?rev=5014&view=rev
> Author:   atkac
> Date:     2012-11-26 12:01:42 +0000 (Mon, 26 Nov 2012)
> Log Message:
> -----------
> Fix handling of whitelisted "vncconfig -set" parameters in Xvnc.

Yes, this was the problem. Fixed in vendordrop 26388.
------- Comment #4 From cendio 2013-05-28 13:10:24 -------
Verified using build 3960 on SLED11 sp2 that title could be set using vncconfig
tool with:

"${TLPREFIX}/bin/vncconfig" -set "desktop=Hello World"

Which works as expected.