www.cendio.com

Bug 4366

Summary: Client does not work on OS X 10.8
Product: ThinLinc Reporter: Peter Åstrand <astrand@cendio.se>
Component: VNCAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 Keywords: hean01_tester
Version: 3.4.0   
Target Milestone: 4.0.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2012-08-02 15:34:00
According to Issue13543, the client does not work on Mac OS X 10.8:

Klienten startar men när man ansluter så får man bara en svart skärm.
Den ser ut att autenticera som den ska. Har testat både med 3.3 och 3.4
klient.
------- Comment #1 From cendio 2012-08-15 10:23:43 -------
I can reproduce the problem now. It seems to happen every time now with our OS
X 10.8. A few strange things, however:

* With 3.4.0, the screen does not update at all, basically. Well, you can get
an update if you switch in and out of fullscreen, but that's it. 

* With the latest nightly build, the screen updates if you resize the window. 

* I've tested with different screens and with/without multiscreen. One strange
thing happened: After running with one screen, the Mac didn't want to use the
VGA output at all; it settled just for the DVI. When this happened, I did a
shutdown and then only connected the VGA port. Started up, then connected the
HDMI/DVI at runtime. Then, both screens worked. BUT! When the second screen was
activated, the OS X Terminal windows turned black, in a similar fashion to
vncviewer. After clicking on them, they were fine. 

I've not managed to repeat this last strangeness, though.
------- Comment #2 From cendio 2012-08-15 10:33:13 -------
> * With the latest nightly build, the screen updates if you resize the window. 

This is due to the new RemoteResize option. If I turn it off, the nightly build
behaves as the 3.4.0 client.
------- Comment #3 From cendio 2012-08-17 15:45:27 -------
Fuck Apple and their god damn developer site. After a lot of digging I managed
to find an old deprecated document that described the proper way to render
custom data. Fixed upstream and updated in r25620.

Tester needs to verify that we do not get a significant performance hit by
changing rendering method.
------- Comment #4 From cendio 2012-10-02 08:33:19 -------
Working as expected client build 3668 on OsX 10.8.1 and 
i was not able to reproduce in any way.