www.cendio.com

Bug 4510

Summary: no debug output from pcsctun on Ubuntu
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: Smart cardAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: derfian@cendio.se
Version: trunkKeywords: aaron_tester
Target Milestone: 4.1.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2012-12-21 10:58:12
We've gotten two separate reports of PCSCTUN_DEBUG not working on Ubuntu. I got
the opportunity to test it out today, and it turns out that Ubuntu's Glib has
some different log settings than we are used to. To get it to work you have to
also set G_MESSAGES_DEBUG=all. I think we can fix this inside pcsctun though.
------- Comment #1 From cendio 2013-03-14 11:41:07 -------
Fixed in r26804.

Tester can also check that G_MESSAGES_DEBUG=pcsctun works.
------- Comment #2 From cendio 2013-03-25 13:02:07 -------
Getting a crash of pcsctun on Windows when it terminates. Assuming it is
because of this bug.
------- Comment #3 From cendio 2013-03-25 13:34:20 -------
Also crashes on Linux.
------- Comment #4 From cendio 2013-03-25 13:44:28 -------
(In reply to comment #3)
> Also crashes on Linux.

Nm. It was just glib that likes to do SIGTRAP on fatal errors. So the crash is
only on Windows.
------- Comment #5 From cendio 2013-03-25 14:33:51 -------
Idiot upstream managed to break static linking on Windows:

https://bugzilla.gnome.org/show_bug.cgi?id=696557

I think I can easily fix it though.
------- Comment #6 From cendio 2013-04-11 15:53:12 -------
Fixed in r26922.
------- Comment #7 From cendio 2013-04-12 10:56:30 -------
Reopening a random pcsctun bug - see bug 4593 for details.
------- Comment #8 From cendio 2013-04-16 14:04:12 -------
*** Bug 4593 has been marked as a duplicate of this bug. ***
------- Comment #9 From cendio 2013-04-17 15:01:34 -------
Fixed again in r27100.
------- Comment #10 From cendio 2013-05-17 10:38:51 -------
Tested from Windows 7 with an exported smart card. Could not reproduce the
crash.

Connecting to an Ubuntu 13.04 server and running:

PCSCTUN_DEBUG=1 pkcs15-tool --list-certificates

gives debug output, as does:

G_MESSAGES_DEBUG=pcsctun pkcs15-tool --list-certificates

Works as expected, so closing.