www.cendio.com

Bug 4569

Summary: Upgrade to PulseAudio 4.0
Product: ThinLinc Reporter: Peter Åstrand <astrand@cendio.se>
Component: SoundAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: derfian@cendio.se
Version: 4.0.0Keywords: astrand_tester, relnotes
Target Milestone: 4.1.1   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:
Bug Depends on:    
Bug Blocks: 4411    
Attachments: Crash dump r27931
Crash dump trunk

Description From cendio 2013-03-28 12:34:40
As bug 4411 mentions, PulseAudio is out. We should consider an upgrade; perhaps
that will solve bug 4411 and other problems.
------- Comment #3 From cendio 2013-07-09 14:33:30 -------
4.0 is out now:

http://www.freedesktop.org/wiki/Software/PulseAudio/Notes/4.0/
------- Comment #4 From cendio 2013-07-10 14:12:30 -------
Have a look at updating these upstream bug entries at the same time:

https://bugs.freedesktop.org/show_bug.cgi?id=55280
https://bugs.freedesktop.org/show_bug.cgi?id=55607
https://bugs.freedesktop.org/show_bug.cgi?id=62865
------- Comment #5 From cendio 2013-07-10 14:13:56 -------
Updated in r27650. Still need to do some follow-up commits. Turns out the newer
PulseAudio needs newer autotools though, so first I have to upgrade cenbuild.
------- Comment #6 From cendio 2013-07-10 16:13:58 -------
Found a minor bug that I've submitted upstream:

https://bugs.freedesktop.org/show_bug.cgi?id=66774
------- Comment #7 From cendio 2013-07-10 16:34:37 -------
Gotten rid of the ALSA use case manager requirement in r27654. Reported
upstream:

https://bugs.freedesktop.org/show_bug.cgi?id=66777
------- Comment #8 From cendio 2013-07-11 14:02:25 -------
Upgrade should be done now.
------- Comment #9 From cendio 2013-07-12 09:57:25 -------
Doesn't build on Windows. Fix in r27667 and submitted upstream:

https://bugs.freedesktop.org/show_bug.cgi?id=66846
------- Comment #10 From cendio 2013-07-16 16:51:27 -------
Upstream wanted improvements to the auto patch. Fixed in r27686.
------- Comment #11 From cendio 2013-09-18 12:37:00 -------
The upgraded caused a regression in the form of bug 4802.
------- Comment #12 From cendio 2013-09-18 12:39:12 -------
*** Bug 4802 has been marked as a duplicate of this bug. ***
------- Comment #13 From cendio 2013-09-18 12:40:35 -------
I've confirmed that it is indeed a regression from 4.1.0 on Henrik's laptop.
------- Comment #14 From cendio 2013-09-18 13:23:12 -------
Problem occurs even without loading module-waveout, so it has nothing to do
with the sound card. It also happens using a simple telnet against the port, so
it is something very fundamental that goes wrong.
------- Comment #15 From cendio 2013-09-23 15:16:05 -------
Urgh. A whole bunch of assorted bugs had to be fixed as part of this:

https://bugs.freedesktop.org/show_bug.cgi?id=69522
https://bugs.freedesktop.org/show_bug.cgi?id=69526
https://bugs.freedesktop.org/show_bug.cgi?id=69708
https://bugs.freedesktop.org/show_bug.cgi?id=69710
https://bugs.freedesktop.org/show_bug.cgi?id=69711
https://bugs.freedesktop.org/show_bug.cgi?id=69712
------- Comment #16 From cendio 2013-09-23 16:55:36 -------
All committed to our repo as well.
------- Comment #17 From cendio 2013-10-17 16:28:52 -------
I've tested sound from:
- CentOS 6
- Windows XP 64-bit
- Windows 7

Sound works perfectly as far as I can tell.
------- Comment #18 From cendio 2013-11-04 14:08:32 -------
Commit r27931 does some changes to tlclient that causes it to crash early in
the login process, when MS App Verifier is active, with the "Handle" test. See
bug 4723. This is a regression compared to 4.1.0. The actual commit does not
reference any bug number, so I'm picking my best guess.
------- Comment #19 From cendio 2013-11-04 14:20:46 -------
Created an attachment (id=497) [details]
Crash dump r27931
------- Comment #20 From cendio 2013-11-04 14:21:03 -------
Created an attachment (id=498) [details]
Crash dump trunk
------- Comment #21 From cendio 2013-11-05 13:26:44 -------
Bug 4815 was the relevant for that commit. Reopening that one instead.