www.cendio.com

Bug 4595

Summary: xprop crashes
Product: ThinLinc Reporter: Aaron Sowry <aaron@cendio.se>
Component: VSM AgentAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 Keywords: aaron_tester
Version: 4.0.0   
Target Milestone: 4.1.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2013-04-15 17:23:19
After logging into a session an error report pops up telling the user that
xprop has crashed. Haven't tried to get any detailed explanation as to why, but
the offending command is apparently:

/opt/thinlinc/libexec/xprop -root 32x \ $0\\n_NET_SUPPORTING_WM_CHECK
------- Comment #1 From cendio 2013-04-16 14:14:33 -------
The original report was for Ubuntu 13.04 Beta, but I also get this on Fedora
18.
------- Comment #2 From cendio 2013-04-17 16:22:58 -------
Our ancient xprop is horribly buggy. It abort():s whenever a property doesn't
exist on a window. I'm amazed we haven't run in to this earlier.

The xprop in Fedora 18 works fine, so I think we'll just try an upgrade.
------- Comment #3 From cendio 2013-04-18 10:45:03 -------
xprop upgraded in r27105.
------- Comment #4 From cendio 2013-05-15 14:50:52 -------
Unable to reproduce using the new xprop on Ubuntu 13.04, so assuming that
upgrading it has solved the problem. Closing.