www.cendio.com

Bug 4658

Summary: Xvnc crashes on reset
Product: ThinLinc Reporter: Aaron Sowry <aaron@cendio.se>
Component: VNCAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 Keywords: aaron_tester
Version: 4.0.0   
Target Milestone: 4.1.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2013-05-24 10:04:48
This was tested on F18.

thinlinc-vnc-server-4.0.0post-3960.x86_64
gnome-shell-3.4.1-6.fc17.x86_64

Xvnc: rrmode.c:265: RRModeInit: Assertion `num_modes == 0' failed.
Aborted

To reproduce:
1. Start an Xvnc server - for example:

$ /opt/thinlinc/libexec/Xvnc :1 -query localhost -geometry 1024x768 -depth 16
-ac +extension Composite passwordFile=~/.vnc/passwd

2. Connect to Xvnc server, e.g.:

$ /usr/bin/vncviewer localhost:1

3. Launch a Gnome Shell session on the Xvnc server. e.g.:

$ DISPLAY=:1 dbus-launch gnome-session --session=gnome

4. Click around a bit, launch some things, move them around and wait for the
crash.
------- Comment #1 From cendio 2013-05-24 11:12:55 -------
It is actually simpler than that. Just starting Xvnc and xterm is enough to
provoke the bug.

What happens is that RandR checks that everything is cleaned up on a server
reset. Apparently we are not doing that properly.
------- Comment #2 From cendio 2013-05-24 12:58:21 -------
Fixed in r27444.
------- Comment #3 From cendio 2013-05-28 14:25:08 -------
Could not reproduce using xterm in an Xvnc session. Closing.