www.cendio.com

Bug 4807

Summary: SeamlessRDP restacking does not work with topmost windows
Product: ThinLinc Reporter: Peter Åstrand <astrand@cendio.se>
Component: | rdesktop (deprecated)Assignee: Peter Åstrand <astrand@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: derfian@cendio.se
Version: trunkKeywords: derfian_tester, relnotes
Target Milestone: 4.1.1   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2013-09-17 15:37:28
During testing of bug 4145, I've noticed that several of the SeamlessRDP test
cases are failing: Restacking does not work very good. 

* With xfwm4-4.8.3-1.el6.x86_64:
Does not warn about restacking issues at startup. However, running multiple IE
windows does not work, amoung other things. 

* With metacity-2.28.0-23.el6.x86_64:
WARNING: Broken Window Manager: Timeout while waiting for ConfigureNotify
WARNING: Broken Window Manager: doesn't handle restack (window was moved to
bottom)

Multiple Windows with IE also does not work.
------- Comment #1 From cendio 2013-09-19 14:56:55 -------
The main reason why this worked so bad was because the IE windows got upgraded
to topmost windows (we were referencing taskmgr, which was topmost).
------- Comment #2 From cendio 2013-09-19 16:56:30 -------
SeamlessRDPShell fixes in vendor drop 27922. rdesktop fixes in vendor drop
27925. 

Tester should test compatibility between old and new versions of the server
side and client side components. Also test multiple WMs.
------- Comment #3 From cendio 2013-10-28 10:56:06 -------
Test case as I understand it:

- In a ThinLinc session...
 * Start taskmgr and a couple of notepads in seamless mode
 * Open a (local) gedit
 * Toggle maximize, minimize, move, resize and whatever
 * Make sure that only the topmost window stays at topmost.
------- Comment #4 From cendio 2013-11-01 13:24:05 -------
Tested kwin, unity2d, openbox (from thinlinc), with thinlinc 4.1.0 & 4.1.1,
wts-tools 4.1.0 & 4.1.1. No crashes found, and I can't reproduce with 4.1.1.