www.cendio.com

Bug 5113

Summary: overlooked XRender operations
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: VNCAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: hean01@cendio.se
Version: trunkKeywords: prosaic
Target Milestone: 4.10.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:
Bug Depends on: 7158    
Bug Blocks:    
Attachments: Screen shot

Description From cendio 2014-04-29 14:02:03
Created an attachment (id=534) [details]
Screen shot

I'm getting rendering bugs with Xfce on Ubuntu 14.04. If you press F5 on the
desktop, it will render the text without the surrounding box (see attached
screen shot). It seems to be a problem with tracking changes though, as
grabbing a screen shot in the session shows that the frame buffer is properly
updated.
------- Comment #1 From cendio 2018-01-22 16:29:46 -------
Reported upstream:

https://github.com/TigerVNC/tigervnc/issues/582
------- Comment #2 From cendio 2018-01-22 16:31:23 -------
I dug around and it turns out that there are a bunch of render operations that
we don't hook in to properly. In this case it seems to be "Trapezoids", but
there are a few others.
------- Comment #3 From cendio 2018-09-13 16:14:45 -------
Fixed in upstream commit 2922e74970 and brought to CTC with vendor drop commit
r33562
------- Comment #4 From cendio 2018-09-13 16:57:51 -------
I could reproduce this problem on Fedora 28 usinf latest Xfce without
compositing, creating a shortcut / folder on desktop using ThinLinc 4.9.0.

Problem is solved when using nightly build.