www.cendio.com

Bug 5151

Summary: resizing seamlessrdp session can cause extra program invocation
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: | rdesktop (deprecated)Assignee: Henrik Andersson <hean01@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: samuel@cendio.se
Version: trunkKeywords: relnotes, samuel_tester
Target Milestone: 4.3.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2014-05-20 12:57:07
Reported on issue 15230.

Resizing your ThinLinc session with this command active:

  tl-run-winapp-seamless notepad.exe

results in another instance of notepad getting executed.

Since RDP doesn't support resizing a session, we reconnect whenever we need to
resize. It seems like we resend the spawn command to seamlessrdpshell when this
happens.

Hopefully just a matter of clearing out those variables once we've sent the
initial command.
------- Comment #1 From cendio 2014-05-28 09:58:57 -------
This is now fixed in upstream commit 1809.
------- Comment #2 From cendio 2014-05-28 10:32:22 -------
Brought to ctc in vendor drop 29021.
------- Comment #3 From cendio 2014-10-08 17:50:37 -------
Looks good, I am not able to reproduce the problem with build 4506 on windows
2008 r2.