www.cendio.com

Bug 5209

Summary: rdesktop connection fails with "disconnect: Invalid licensing message."
Product: ThinLinc Reporter: Peter ├ůstrand <astrand@cendio.se>
Component: | rdesktop (deprecated)Assignee: Henrik Andersson <hean01@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: jonas.nordell@forsakringskassan.se, samuel@cendio.se
Version: 4.2.0Keywords: relnotes, samuel_tester
Target Milestone: 4.3.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2014-07-09 11:02:35
In some cases, rdesktop fails to connect to Windows with error:

disconnect: Invalid licensing message.

There are two reports about this on the net:

https://bugs.mageia.org/show_bug.cgi?id=13526
https://bugs.archlinux.org/task/40785

Apparently this is a regression in 1.8.2, since it works with 1.8.1 for some.
------- Comment #3 From cendio 2014-08-11 08:45:32 -------
I can't reproduce this issue but my guts says the following commit is the
source to the problem... Before this commit, there was a mini protocol loop
which waited for a license handling to be finished before continuing with the
main rdp protocol loop. When this loop was removed the main loop is running
however the UI is also created and could create packets (mouse moves etc...)
were a license packet was expected by the server.

  r1794 | hean01 | 2014-04-23 08:11:55 +0200 (Wed, 23 Apr 2014) | 12 lines

  Remove process of packets in rdp_connect.

  The process of packets in rdp_connect assumes that the
  first packets are demand active to set g_rdp_shareid which
  is not true. In case when CredSSP+Kerberos is in use an
  enhanced redirection PDU packet is sent before the demande
  active PDU.

  This fixes the problem with rdesktop silently exists in
  the case above.

Possible solution is to create UI when g_rdp_shareid is true in the main loop.
------- Comment #4 From cendio 2014-08-18 08:46:13 -------
(In reply to comment #3)
>   r1794 | hean01 | 2014-04-23 08:11:55 +0200 (Wed, 23 Apr 2014) | 12 lines

Regression of bug 4920
------- Comment #5 From cendio 2014-08-27 14:24:14 -------
(In reply to comment #4)
> (In reply to comment #3)
> >   r1794 | hean01 | 2014-04-23 08:11:55 +0200 (Wed, 23 Apr 2014) | 12 lines
> 
> Regression of bug 4920

Upstream commits:

r1823 - Reverts 1794 which fixes, Invalid license message.
r1825 - New implementation to fix bug #4920
------- Comment #6 From cendio 2014-08-27 15:04:26 -------
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > >   r1794 | hean01 | 2014-04-23 08:11:55 +0200 (Wed, 23 Apr 2014) | 12 lines
> > 
> > Regression of bug 4920
> 
> Upstream commits:
> 
> r1823 - Reverts 1794 which fixes, Invalid license message.
> r1825 - New implementation to fix bug #4920

Vendordrop to ctc in commit r29292
------- Comment #7 From cendio 2014-08-29 09:00:34 -------
We couldn't reproduce this issue internally, but end customer has verified that
the issue is fixed using nightly build of rdesktop package.
------- Comment #8 From cendio 2014-08-29 09:02:01 -------
Now we just need to verify that the other changes related to bug #4920 is
working as expected.
------- Comment #9 From cendio 2014-09-02 12:56:06 -------
(In reply to comment #8)
> Now we just need to verify that the other changes related to bug #4920 is
> working as expected.

With complementary fix for upstream commit r1827 to r1825 reimplementation for
bug #4920 is working correctly.
------- Comment #10 From cendio 2014-09-02 13:16:14 -------
Fixed in ctc with commit 29317.

Tester should test, CredSSP + Kerberos redirection see #4920 for details.
------- Comment #11 From cendio 2014-09-25 16:24:14 -------
(In reply to comment #10)
> Tester should test, CredSSP + Kerberos redirection see #4920 for details.

Works when using 2012 r2.
------- Comment #12 From cendio 2014-10-08 13:34:45 -------
(In reply to comment #10)
> Tester should test, CredSSP + Kerberos redirection see #4920 for details.

Works when using 2008 r2.
------- Comment #13 From cendio 2014-10-09 14:19:11 -------
(In reply to comment #10)
> Tester should test, CredSSP + Kerberos redirection see #4920 for details.

Works when using windows 2012. Closing