www.cendio.com

Bug 5335

Summary: upgrade to FLTK 1.3.3
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: Build systemAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: astrand@cendio.se, hean01@cendio.se
Version: pre-1.0Keywords: hean01_tester, prosaic
Target Milestone: 4.4.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2014-11-04 09:49:27
It was released yesterday and should contain all of our modifications. I.e. we
can use it without any extra patches.
------- Comment #1 From cendio 2014-11-19 13:38:42 -------
Urgh. They've fiddled around with the CMake stuff quite a bit. Need to tweak
our spec file to compensate.
------- Comment #2 From cendio 2014-11-19 13:39:24 -------
fltk-config is also gone for CMake-builds, so we need to change how tlclient is
built.
------- Comment #3 From cendio 2014-12-11 16:52:59 -------
Upgrade in r29721. tlclient tweaked in r29722.

Need to check that all our features work as well. Waiting for a build.
------- Comment #4 From cendio 2015-02-03 14:44:16 -------
I've now tested our patches on Linux, Windows and OS X. Can't find any
problems.
------- Comment #5 From cendio 2015-04-14 15:35:53 -------
Tested all ui elements and logics, clipboard on Linux, Windows and OSX using
client build 4723, everything works as expect except i stumble upon crashes in
vncviewer on OSX platform.

Need to investigate that crash more if it related to this upgrade.
------- Comment #6 From cendio 2015-04-15 09:36:24 -------
(In reply to comment #5)
> Need to investigate that crash more if it related to this upgrade.

The crash is not reproducible using 4.3.0 client.
------- Comment #7 From cendio 2015-04-15 11:58:54 -------
(In reply to comment #6)
> (In reply to comment #5)
> > Need to investigate that crash more if it related to this upgrade.
> 
> The crash is not reproducible using 4.3.0 client.

It's fastest and most consequently reproducible while using gedit in the
session and while selecting a text move mouse around over text. Each new
selection will produce copy to clipboard which is transferred to the client.
------- Comment #8 From cendio 2015-04-15 13:47:13 -------
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > Need to investigate that crash more if it related to this upgrade.
> > 
> > The crash is not reproducible using 4.3.0 client.
> 
> It's fastest and most consequently reproducible while using gedit in the
> session and while selecting a text move mouse around over text. Each new
> selection will produce copy to clipboard which is transferred to the client.

The issue seems to only affect OSX build
------- Comment #9 From cendio 2015-04-16 13:54:02 -------
I tested to reproduce the issue with build 4605 which is a version using fltk
1.3.3 but before the gcc upgrade. I succesfully reproduced the crash.
------- Comment #10 From cendio 2015-04-20 14:11:37 -------
Poor buffer management in the OS X clipboard code that lead to a buffer
overflow. Fixed upstream in r10709, and locally in r30253.
------- Comment #11 From cendio 2015-04-24 07:24:27 -------
(In reply to comment #10)
> Poor buffer management in the OS X clipboard code that lead to a buffer
> overflow. Fixed upstream in r10709, and locally in r30253.

Verified using build 4734, can't reproduce the crash anymore.
------- Comment #12 From cendio 2015-04-24 07:26:52 -------
As of testing reported on comment #5 and some minor retesting with the latest
build everything seems good.

Closing.