www.cendio.com

Bug 5480

Summary: horizontal scroll events are sent as vertical scroll
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: Web AccessAssignee: Samuel Mannehed <samuel@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: astrand@cendio.se, samuel@cendio.se, thoni56@cendio.se
Version: pre-1.0Keywords: relnotes, thomas_tester, upstream
Target Milestone: 4.8.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:
Bug Depends on:    
Bug Blocks: 6132    

Description From cendio 2015-03-25 14:02:16
Using the horizontal scroll on a mouse with the HTML client ends up sending
mouse buttons 4/5, not 6/7 as is expected.
------- Comment #3 From cendio 2016-10-21 16:13:00 -------
https://github.com/kanaka/noVNC/pull/696
------- Comment #4 From cendio 2017-01-10 16:46:24 -------
*** Bug 6130 has been marked as a duplicate of this bug. ***
------- Comment #6 From cendio 2017-02-03 16:25:51 -------
This is fixed now.
------- Comment #7 From cendio 2017-02-08 12:13:49 -------
Tested with wide web page in Firefox, and a enlarged Writer document. Scrolls
up, down, left and right correctly.