www.cendio.com

Bug 5810

Summary: possible incorrect shadow notification on reconnect
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: OtherAssignee: Henrik Andersson <hean01@cendio.se>
Status: CLOSED FIXED QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: ossman@cendio.se
Version: pre-1.0Keywords: focus_shadowing, ossman_tester, relnotes
Target Milestone: 4.9.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2016-02-26 12:39:36
Bug 2251 gave us the ability to tell shadowers and "normal" connections apart.
This give us the option to fix this corner case:

 1. A user starts a session and connects

 2. A shadower connects and a notification pops up (CORRECT)

 3. The user disconnects, but the shadower remains.

 4. The user reconnects an a notification pops up (INCORRECT)

This is because we merely look at the number of the connections right now, not
their type.
------- Comment #1 From cendio 2016-02-29 11:12:56 -------
Is this a duplicate of bug 5737?
------- Comment #2 From cendio 2016-03-01 15:33:16 -------
Consider getting rid of connection counting altogether and only rely on the
shadower connection event to trigger a warning. While it would not get rid of
the race, it would make it less likely to happen.
------- Comment #3 From cendio 2017-10-24 09:43:27 -------
This got fixed as part of bug 37/bug 5737.