www.cendio.com

Bug 5835

Summary: unfsd gives access denied to some versions of mount.nfs
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: Local drive redirectionAssignee: Pierre Ossman <ossman@cendio.se>
Status: CLOSED DUPLICATE QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: ossman@cendio.se
Version: pre-1.0   
Target Milestone: 4.6.0   
Hardware: PC   
OS: Unknown   
Bug Depends on:    
Bug Blocks: 5829    

Description From cendio 2016-04-04 15:02:58
I'm seeing this on Fedora 23 and Ubuntu 16.04:

> Running /opt/thinlinc/etc/xstartup.d/40-tl-mount-localdrives (Mounting local drives)
> mount.nfs: access denied by server while mounting localhost:@otp:ba528263c7066f62f325355b621c6874/local/home/ossman

Oddly enough it doesn't seem to be because they both have modern versions of
nfs-utils. Fedora 23 has 1.3.3 and Ubuntu 16.04 has 1.2.8, but RHEL 7 has 1.3.0
and everything works fine there.
------- Comment #1 From cendio 2016-04-08 13:25:49 -------
Turns out it has nothing to do with mount.nfs or anything else in the
distribution. We are miscalculating the OTP because of bug 2251.

*** This bug has been marked as a duplicate of bug 2251 ***