www.cendio.com

Bug 6060

Summary: The UI state for keyboard button is easy to make out of sync
Product: ThinLinc Reporter: Peter ├ůstrand <astrand@cendio.se>
Component: Web AccessAssignee: Samuel Mannehed <samuel@cendio.se>
Status: CLOSED DUPLICATE QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: astrand@cendio.se
Version: trunk   
Target Milestone: 4.7.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:

Description From cendio 2016-10-17 12:11:23
Tested on Windows 10 Mobile, but as far as I know a problem which appears on
all devices:

1. Bring up the keyboard by pressing the keyboard button.

2. Close the keyboard from the keyboard itself, ie press the device back button

Now, the keyboard button is still highlighted, and the code still believes that
the keyboard is active/visible. If you press the button again, the button will
be longer be highlighted, but nothing else happens, because the keyboard was
already hidden. 

As far as we know, fixing this is difficult since it is not possible to
determine if the keyboard is visible or not. Instead, my suggestion is to
change the button from "toggle keyboard" to "activate keyboard". The code would
need to re-set focus to the input field so that the keyboard is visible for
sure.
------- Comment #1 From cendio 2016-10-18 08:33:17 -------
(In reply to comment #0)
> Tested on Windows 10 Mobile, but as far as I know a problem which appears on
> all devices:

None of the browsers on iOS have this problem. This is a problem on Android and
Windows mobile.
------- Comment #2 From cendio 2016-10-18 15:01:54 -------

*** This bug has been marked as a duplicate of bug 5547 ***