www.cendio.com

Bug 6082

Summary: remove web integration (tlclient.cgi)
Product: ThinLinc Reporter: Pierre Ossman <ossman@cendio.se>
Component: VSM ServerAssignee: Henrik Andersson <hean01@cendio.se>
Status: NEW QA Contact: Bugzilla mail exporter <bugzilla-qa@cendio.se>
Severity: Normal    
Priority: P2 CC: ossman@cendio.se, samuel@cendio.se
Version: 1.3.1   
Target Milestone: ProductCouncil   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:
Bug Depends on: 4521, 5190    
Bug Blocks:    

Description From cendio 2016-11-01 15:16:04
It relies on Java for a lot of its functionality, we believe it is lightly
used, and many customers confuse it with the HTML client. As such the downsides
seem to cancel out any benefit.
------- Comment #1 From cendio 2016-11-01 15:22:34 -------
The product council approves of removing this functionality. Two requirements
though:

 - An attempt should be made to retain shadowing in tlwebadm, provided it
doesn't require a massive effort.

 - The removed code should be donated to https://github.com/oetiker/tl-extras,
if they are interested
------- Comment #2 From cendio 2016-11-01 15:33:15 -------
(In reply to comment #1) 
>  - An attempt should be made to retain shadowing in tlwebadm, provided it
> doesn't require a massive effort.

Bug 4928 covers implementing shadowing support for the HTML5 client.
------- Comment #3 From cendio 2016-11-07 17:09:53 -------
(In reply to comment #2)
> (In reply to comment #1) 
> >  - An attempt should be made to retain shadowing in tlwebadm, provided it
> > doesn't require a massive effort.
> 
> Bug 4928 covers implementing shadowing support for the HTML5 client.

Shadowing does not have to be implemented in the HTML5 client for this. We
could keep the native client configuration file generation function and move it
into tlwebadm.
------- Comment #4 From cendio 2016-11-08 14:07:10 -------
Completely removing this feature is probably premature. But we can mitigate
some of the most glaring problems:

 - No Java these days (bug 4521)

 - Confusion in tl-setup (bug 5190)