Bug 7383

Summary: Edge always shows default browser cursor
Product: ThinLinc Reporter: Pierre Ossman <ossman>
Component: Web AccessAssignee: Niko Lehto <nikle>
Status: CLOSED FIXED    
Severity: Normal CC: aleta, nikle
Priority: P2 Keywords: relnotes, upstream
Version: trunk   
Target Milestone: 4.11.0   
Hardware: PC   
OS: Unknown   
Acceptance Criteria:
Bug Depends on: 7365    
Bug Blocks:    

Description Pierre Ossman cendio 2019-10-08 09:57:08 CEST
With the latest edge something goes wrong with the cursor handling and we always get the default cursor of the local system instead of the cursor used in the session.

We can see this with versions of ThinLinc that has worked before, so this is caused by some change in Edge. IE still works fine though.

After some digging we discovered that the detection for data URI support was broken. Instead of actually detecting what we intended, the code really tested if the browser supported fallback cursors (i.e. "cursor: a, b, c;"). That happened to overlap well with support for data URI cursors, but it seems Edge has now implemented support for fallback but not data URI.

Fixed upstream here:

https://github.com/novnc/noVNC/commit/a1afb2a

So we just need a vendor drop.
Comment 1 Niko Lehto cendio 2019-10-22 10:47:04 CEST
Verified on nightly build (6272) after vendor drop. 
Tested on Edge 18 and IE 11. Edge now uses fallback cursor as intended alike IE.
Comment 3 Alex Tanskanen cendio 2019-10-22 13:47:04 CEST
The release notes looks good, however, it should say "Microsoft Edge" instead of just "Edge"