www.cendio.com
Bug 1920 - Test installation and upgrade on Solaris 10
: Test installation and upgrade on Solaris 10
Status: CLOSED FIXED
: ThinLinc
Other
: 1.4.1
: PC Linux
: P2 Normal
: 4.4.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-04-19 08:51 by
Modified: 2015-10-15 10:21 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2006-04-19 08:51:19

    
------- Comment #1 From cendio 2006-05-17 16:27:07 -------
Works (not text though, but that has its own bug).
------- Comment #2 From cendio 2007-03-01 11:11:07 -------
Basic functionality works. 
------- Comment #3 From cendio 2008-01-31 11:17:53 -------
Whatever you do when you test this bug, DO NOT FORGET TO ENABLE SSH TCP PORT
FORWARDING!

Starting a session seems to work. I'm too lazy to test printers as CUPS is not
installed. 

Trouble starting the installer when locale is set to something else than C, but
that has its own bug.
------- Comment #4 From cendio 2008-07-08 12:48:46 -------
A few notes, to reduce future pain:

* Make sure you remove ALL references of nis in /etc/nsswitch.conf. 

* Had to install lsof from sunfreeware.com. 

* Sane PATH:
export PATH=/usr/sbin:/usr/bin:/opt/sfw/bin:/usr/sfw/bin:/usr/local/bin

* Start the installation with:
DISPLAY="" PYTHON=/usr/sfw/bin/python ./install-server

* To create a test user:
useradd user1
passwd user1
mv /home /oldhome
mkdir /home
mkdir /home/user1
chown user1 /home/user1

* sshd_config contains stupid:
AllowUsers root
AllowTcpForwarding no


Works though. 
------- Comment #5 From cendio 2009-05-08 10:19:29 -------
Works on Sunray.
------- Comment #6 From cendio 2010-04-28 13:00:14 -------
Reproducible UI fail when upgrading on Solaris - the dialogue box with the
pkgrm messages is not cleared before the install progress bar is shown.
------- Comment #7 From cendio 2010-04-28 13:17:52 -------
Also, vsmserver started from tl-setup.py refuses to connect to an existing
agent. Restarting vsmserver manually fixes this problem.
------- Comment #8 From cendio 2011-08-10 13:02:42 -------
Upgrading from 3.1.2 to 3.2.0 (3128) fails because uninstall scripts in 3.1.2
doesn't work. Running install-server a couple of times will let it continue on
further, but it'll eventually stop on removing CENDthinlinctladm.

You'll have to edit /var/sadm/pkg/CENDthinlinctladm/install/preremove by hand
to remove the bad if statement to make the problem go away. Unless we decide to
patch the preremove script from install-server, I don't see how we can solve
this by code. We can make sure that it won't happen again by always testing
that our packages uninstall cleanly on Solaris as it is a vital part of the
upgrade routine.

Installing from scratch works like a charm, with DISPLAY=''.

The problem mentioned in comment 7 is still there.
------- Comment #9 From cendio 2011-12-27 16:42:38 -------
Clean installation worked fine, with the exception of the known issues:

 - You have to restart vsmserver because of a race
 - You have to manually kill tlstunnel and start tlwebadm because of another
race
------- Comment #10 From cendio 2011-12-29 10:38:50 -------
Upgrade from 3.2.0 seems to work fine as well. Running sessions are kept
functional.
------- Comment #11 From cendio 2012-05-31 16:02:37 -------
Situation remains as in previous tests.
------- Comment #12 From cendio 2012-11-02 15:14:51 -------
Testing performed on sunray.lkpg.cendio.se with a fresh install of Solaris 10
u10, the latest Solaris 10 version at the time of the tests.

* Configured SSH to allow port forwarding, as per Platform Specific Notes.
* Installed ThinLinc 4.0.0 in text mode, works great.
* Rolled back to pre-ThinLinc snapshot, installed 3.4.0, upgraded to 4.0.0.
Works great.

Most comments in comment #4 are no longer valid, no need to set set PATH,
DISPLAY or PYTHON.

Regarding users and home directories:
 /home is a mount point for automount, so don't move it around.

 First time, run this:
 echo "* sunray:/export/home/&" >> /etc/auto_home
 svcadm restart autofs

 Then for each user:
 useradd <user>
 passwd <user>
 mkdir /export/home/<user>
 chown <user> /export/home/<user>
------- Comment #13 From cendio 2013-06-27 11:25:23 -------
Tested upgrade on "sunray". Checked:

* tlwebadm
* VSM
* Logging in, starting Java desktop
* Resizing the session
* Mahjongg
* Firefox
* /usr/openwin/demo/worm

Solaris is as fun as always...
------- Comment #14 From cendio 2013-11-08 13:56:44 -------
Clean installation and upgrade from 4.1.0 both work fine.
------- Comment #15 From cendio 2014-05-19 14:40:14 -------
Clean install and upgrade from 4.1.1 works fine with 4.2.0rc3.

This issue still affects us though:
 - You have to restart vsmserver because of a race
------- Comment #16 From cendio 2014-10-23 13:54:48 -------
Works well.
------- Comment #17 From cendio 2015-06-04 18:50:27 -------
Both install and upgrade from 4.3.0 works fine with 4.4.0rc5.

Played around with tlwebadm and a ThinLinc session. A brief test, but no
problems found so far.