www.cendio.com
Bug 2554 - TLS support in rdesktop
: TLS support in rdesktop
Status: CLOSED DUPLICATE of bug 4347
: ThinLinc
| rdesktop (deprecated)
: trunk
: PC Linux
: P2 Enhancement
: 4.0.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-10-23 15:46 by
Modified: 2012-11-28 12:07 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2007-10-23 15:46:27
Currently, rdesktop is encrypting its communication with md5, with an unsecure
key exchange using RSA public key encryption.

Since W2003SP1, there is a possibility to use TLS instead.
http://blogs.technet.com/tristank/archive/2005/02/24/379380.aspx has some
details while
http://technet2.microsoft.com/windowsserver/en/library/a92d8eb9-f53d-4e86-ac9b-29fd6146977b1033.mspx?mfr=true
documents the setup, which includes certficate authority configuration.
------- Comment #3 From cendio 2012-06-20 12:25:49 -------

*** This bug has been marked as a duplicate of bug 4347 ***