www.cendio.com
Bug 2968 - Investigate AIGLX support, for Compiz etc
: Investigate AIGLX support, for Compiz etc
Status: CLOSED FIXED
: ThinLinc
VNC
: trunk
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
: 4417
:
  Show dependency treegraph
 
Reported: 2008-11-21 11:23 by
Modified: 2013-05-23 09:51 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2008-11-21 11:23:27
With our new X.Org 7.4 based Xserver, I think we can actually support AIGLX,
meaning that Compiz etc should work. A quick test on my FC9 laptop fails,
though:

compiz (core) - Fatal: Root visual is not a GL visual
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :1.0

I've tried changing to -depth 24, but this doesn't help.
------- Comment #1 From cendio 2008-11-21 11:33:45 -------
Tried KDE as well, it says:

kwin(23387): Couldn't find framebuffer configuration for depth 32 (no ARGB GLX
visual)!
kwin(23387): Failed to initialize compositing, compositing disabled
kwin(23387): Consult
http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up

The problem might be that we are not using 32 bit bpp. I tried using -depth 32,
but Xvnc still starts with depth 24. 
------- Comment #2 From cendio 2013-04-23 11:50:48 -------
We've had working AIGLX for some time now. Compiz also works, at least on
Fedora 18.
------- Comment #3 From cendio 2013-05-23 09:51:03 -------
Xvnc no longer crashes, but compiz does:

compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Segmentation fault (core dumped)

Reported upstream:
https://bugzilla.redhat.com/show_bug.cgi?id=966369

However, other GLX stuff works, so I'd say this bug is fixed.