www.cendio.com
Bug 3060 - Test installation and upgrade on SLED11 SP3 (64-bit)
: Test installation and upgrade on SLED11 SP3 (64-bit)
Status: CLOSED FIXED
: ThinLinc
Other
: trunk
: PC Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2009-04-01 13:55 by
Modified: 2015-05-07 16:02 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2009-04-01 13:55:43

    
------- Comment #1 From cendio 2009-05-07 10:20:50 -------
I've been doing all my testing on SLED11 and it works quite good. Not tested
upgrade though, since earlier versions of TL does not run. 
------- Comment #2 From cendio 2010-03-30 14:13:32 -------
Tester should check that /opt/thinlinc/bin/tl-vdi-tool gets installed setgid
root
------- Comment #3 From cendio 2010-04-29 11:19:03 -------
Been using SLED11 for all my tests. tl-vdi-tool is correctly setgid. 

Tested upgrade from 3.0.0, works ok. 

Tested gtkperf. With 3.1.0, it actually executes 45% faster than with 3.0.0.
Nice. 
------- Comment #4 From cendio 2011-08-09 10:48:33 -------
Tested upgrade from 3.1.2, works ok. Clean installation as well. gtkperf
performance is the same. Youtube with sound works good. 
------- Comment #5 From cendio 2011-12-22 18:00:14 -------
Limited testing has been done, but nothing with the beta builds or later.

SLED11 machine copied to /import/vmware-images.
------- Comment #6 From cendio 2011-12-28 12:51:13 -------
I have installed 3.2.0 on a clean SLED11 64bit machine and then
connected/discnonected from a session with a user, update the server
to 3.3.0 build 3309 and reconnected to same session, logged out and
created a new with success..
Tested some basics and performance change was very notable while playing
a youtube clip.. 
------- Comment #7 From cendio 2011-12-28 13:40:57 -------
I have also tested some basic redirections, scard thru 
client->wts->netid, sound which also works as expected..
------- Comment #8 From cendio 2011-12-28 14:50:23 -------
Closing this bug now after some testing..
------- Comment #9 From cendio 2012-05-29 17:15:24 -------
Installation of latest nightly build works fine - I have also done a lot of
installation testing on SLED 11 while testing tl-setup.

Upgrade from 3.3.0 to nightly also appears to be okay. Closing.
------- Comment #10 From cendio 2012-05-31 16:14:07 -------
Tested with 3.4.0rc1.

Updates fine from 3.3.0 on SLED11 SP2. Installation on a fresh install also
goes without problems. Closing.
------- Comment #11 From cendio 2012-11-12 15:54:21 -------
Unfortunately, bug 4416 happens basically all the time.
------- Comment #12 From cendio 2012-11-12 16:40:09 -------
(In reply to comment #11)
> Unfortunately, bug 4416 happens basically all the time.

Not a regression though. Perhaps related to a particular set of updates. We
haven't had any reports of this problem for 3.4.0 @ SLED11, so we can probably
live with this bug for now, provided that we have the workaround. 

Besides the problem above, the installation seems to work fine on SLED11. Good
enough for me.
------- Comment #13 From cendio 2013-06-24 09:52:40 -------
Verified upgrade from 4.0.0 to 4.1.0 build 3993, everything seems to work as
expected.
------- Comment #14 From cendio 2013-06-24 09:54:54 -------
I have done alot of testing of ThinLinc 4.1.0 on SLED 11 Sp2 while testing the
other bugs without any issues (except those reported and fixed).
------- Comment #15 From cendio 2013-11-11 16:38:10 -------
Tested 4.1.1 rc1 on SLED11 Sp3:

* Upgrade from 4.1.0
 - Works as expected, however installation of 4.1.0 needed some manual   
   intervention due to a bug in packageinstaller of tl-setup which is fixed for 
   4.1.1 release.

* New installation on system with all updates
 - Works as expected

* Installation
 - Works as expected

* Performance and sound via Youtube playback
 - Youtube playback fails due to outdated adobe flash.
 - Youtube HTML5 playback fails too
 - Also fails to install Google chrome due to missing req deps on lower version 
   of x11 libs than shipped with SLED11 Sp3
 - Downloaded 7 different clips (codecs) but i failed to played anythin of them 
   using shipped codecs / applications...

* Thindrives
 - Works as expected, copy of 100mb files, basic tests from nautilus and
terminal.

* thinlocal print,
  - works as expected

* smart cards,
 - Works as expected 

* tlwebadm, 
 - Works as expected

* tlwebaccess
 - Works as expected

* OTP
 - Works as expected

* rdesktop against 2008r2 testserver, with sound/smartcard
 - works as expected
------- Comment #16 From cendio 2014-05-07 09:24:08 -------
(In reply to comment #15)
Tested 4.2.0 build 4347 on SLED11 Sp3:

* Upgrade from 4.1.1
  - Works as expected

* New installation on system with all updates
  - Works as expected

* Performance and sound via Youtube playback
  - Youtube playback works great after installing the latest updates

* Sound works great, even the login sound. 

* Thindrives
  - Works as expected, tested saving and reading tl-4.1.1-clients.zip. 

* thinlocal print,
  - works as expected

* smart cards,
 - Works as expected 

 * tlwebadm, 
  - Works as expected

 * tlwebaccess
  - Works as expected

 * rdesktop against 2008r2 testserver, with sound/smartcard
  - works as expected. Some sound glitches, but works good overall, even with
youtube in IE.
------- Comment #17 From cendio 2014-10-20 16:07:50 -------
Tested 4.3.0 build 4528 on SLED11 Sp3:

* Upgrade from 4.2.0
  - Works as expected
------- Comment #18 From cendio 2014-10-21 14:18:17 -------
Tested build 4529. 

* New installation on system with all updates
  - Works as expected

* Performance and sound via Youtube playback
  - Youtube playback works great after installing the latest updates

* Sound works great, even the login sound. 

* Thindrives
  - Works as expected. 

* thinlocal print,
  - works as expected

* smart cards,
 - Works as expected 

* tlwebadm, 
  - Works as expected

* tlwebaccess
  - Works as expected

* rdesktop against 2003 testserver, with sound/smartcard
  - works as expected. Some sound glitches, but works