www.cendio.com
Bug 3104 - Import new vendor drop of unfs3
: Import new vendor drop of unfs3
Status: CLOSED FIXED
: ThinLinc
Local drive redirection
: trunk
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2009-04-24 11:51 by
Modified: 2013-05-28 08:53 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2009-04-24 11:51:54
Lot's of fixes in unfs3, recently. We should follow upstream.
------- Comment #1 From cendio 2012-11-22 09:17:07 -------
Sourceforge has *finally* made me admin over the abandoned unfs3 project. See
https://sourceforge.net/p/forge/site-support/1636/. Let's fix things now.
------- Comment #2 From cendio 2012-11-22 09:18:25 -------
*** Bug 3105 has been marked as a duplicate of this bug. ***
------- Comment #3 From cendio 2012-11-26 09:18:45 -------
Upstream project has been fixed, and a new vendor drop has been imported.
Tested briefly on Windows and Linux. 

The tester should check the upstream project, SVN repo, web page etc, plus test
the local drives functionality on all platforms.
------- Comment #4 From cendio 2013-05-07 13:24:32 -------
> Tested using build 3939.
> 
> Creating a folder in the root of mount in finder fails like this;
> 
> First a folder named "untitled folder" is created and user is instructed to
> name the folder, which will fail with rename file to new name with "Device or
> resource busy". Leaving a folder "untitled folder" which cant be renamed.
> 
> 
> Creating a folder in subdirectory of mount in finder fails like above but with
> error messages "Stale NFS Handle".
> 
> 
> When going into a subfolder content is not show, repeatedly hits on F5
> (refresh) in finder makes some of the content to be shown.

Taken from #2180, because, its reproducible with ThinLinc windows client.
------- Comment #5 From cendio 2013-05-21 11:03:27 -------
(In reply to comment #4)
> > Tested using build 3939.
> > 
> > Creating a folder in the root of mount in finder fails like this;
> > 
> > First a folder named "untitled folder" is created and user is instructed to
> > name the folder, which will fail with rename file to new name with "Device or
> > resource busy". Leaving a folder "untitled folder" which cant be renamed.
> > 
> > 
> > Creating a folder in subdirectory of mount in finder fails like above but with
> > error messages "Stale NFS Handle".
> > 
> > 
> > When going into a subfolder content is not show, repeatedly hits on F5
> > (refresh) in finder makes some of the content to be shown.
> 
> Taken from #2180, because, its reproducible with ThinLinc windows client.

Moved to bug 4645.
------- Comment #6 From cendio 2013-05-28 08:53:50 -------
I have done alot of testing regarding unfsd due to the issues encountered which
is added to bug #4645, however i could not find a regression with the upgrade
of unfsd so i'm closing this bug.