www.cendio.com
Bug 3404 - Rewrite the rdesktop smart card implementation
: Rewrite the rdesktop smart card implementation
Status: CLOSED WONTFIX
: ThinLinc
| rdesktop (deprecated)
: 3.0.0
: PC Unknown
: P2 Normal
: 4.10.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2010-01-26 13:20 by
Modified: 2019-02-07 15:51 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2010-01-26 13:20:07
The rdesktop smart card implementation is very bad. It uses locks and threads
apparently without reason, has a lot of dead code, and doesn't work correctly
on 64 bit platforms. It smells ugly as well. Basically, it needs a complete
rewrite.
------- Comment #1 From cendio 2012-12-21 12:36:54 -------
*** Bug 4083 has been marked as a duplicate of this bug. ***
------- Comment #2 From cendio 2013-07-05 12:36:13 -------
Found another reason for a rewrite. The RDP smart card protocol uses the DCE
RPC standard for encoding calls. But rdesktop doesn't make any attempt to
properly parse this. Instead it assumes a very fixed layout. This is bound to
fail at some point.
------- Comment #3 From cendio 2013-07-05 13:45:22 -------
(In reply to comment #2)
> Found another reason for a rewrite. The RDP smart card protocol uses the DCE
> RPC standard for encoding calls. But rdesktop doesn't make any attempt to
> properly parse this. Instead it assumes a very fixed layout. This is bound to
> fail at some point.

This is no longer a theoretical problem. Bug 4741 is the first instance of this
crappy parsing failing under real world scenarios.
------- Comment #5 From cendio 2014-09-05 10:19:23 -------
See also bug 3571 about redesigning pcsctun to deal with pcsc-lite's
crappiness. Probably need to use a similar design for rdesktop.
------- Comment #6 From cendio 2019-02-07 15:43:20 -------
rdesktop (and associated tools) is being removed from the ThinLinc product.