www.cendio.com
Bug 3716 - Turkish characters not working properly in Xvnc when faking keypresses
: Turkish characters not working properly in Xvnc when faking keypresses
Status: CLOSED FIXED
: ThinLinc
Client
: pre-1.0
: PC All
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-01-11 18:00 by
Modified: 2014-05-05 12:43 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2011-01-11 18:00:46
When we started doing a PoC in turkey, we quickly noticed that tlclient has
serious problems with Turkish characters. Both the Windows and Linux client are
broken.

The Windows client is completely screwed. You get random other characters
instead of the ones you want. Looking at the code I see some references to
latin-1, so perhaps it simply cannot handle any character outside of that...

For Linux, almost everything works. Just the turkish I:s seem to broken.
Looking at xev, I see that in one case I get a weird keysym, and in the other
case I get a combination of a dead character and a regular I. I guess Peter's
dead character hack shouldn't be used for every dead sym we can find...
------- Comment #1 From cendio 2011-01-12 14:21:14 -------
Did some more testing here:

- Client is sending the correct keysyms. IOW, problem is in Xvnc
- The key combinations that Xvnc are faking should work. When using them
locally, they give the proper result.
------- Comment #2 From cendio 2011-01-13 17:12:17 -------
Problem appears on RHEL 6, but not RHEL 5. Probably caused by a newer Xlib.
------- Comment #4 From cendio 2013-12-04 11:07:50 -------
We've rewritten both the client and server keyboard handling since this bug was
opened. We've also done a lot of testing with non-latin-1 keyboards. So we
consider this bug fixed.
------- Comment #5 From cendio 2014-05-05 12:43:23 -------
Works with Linux and OS X Client.