www.cendio.com
Bug 3796 - Consider calling ck-{xinit,launch}-session
: Consider calling ck-{xinit,launch}-session
Status: CLOSED WONTFIX
: ThinLinc
VSM Agent
: 3.1.2
: PC Linux
: P2 Enhancement
: 4.9.0
Assigned To:
:
:
: 357
:
  Show dependency treegraph
 
Reported: 2011-03-31 14:49 by
Modified: 2017-06-13 13:22 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2011-03-31 14:49:31
Moved from bug 357:

> Modern systems also wants to have a consolekit session. We can probably solve
> this by inserting ck-launch-session somewhere in the process.

It's not obvious if we should use ck-xinit-session or ck-launch-session. No
documentation for these tools are available, not even --help!
------- Comment #1 From cendio 2011-04-26 11:56:24 -------
I had a quick look at this, and it seems we might have to do this from
tl-session/tl-xinit. You need to keep the dbus socket alive for as long as the
session is alive as termination is interpreted as the session having crashed.
------- Comment #2 From cendio 2011-11-03 10:38:37 -------
*** Bug 4041 has been marked as a duplicate of this bug. ***
------- Comment #3 From cendio 2017-06-13 13:22:03 -------
ConsoleKit has been replaced by logind which works nicely with ThinLinc.