Bug 3836 - get gnome-shell running in ThinLinc
Summary: get gnome-shell running in ThinLinc
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Other (show other bugs)
Version: 3.1.2
Hardware: PC Linux
: P2 Enhancement
Target Milestone: 4.1.0
Assignee: Pierre Ossman
URL:
Keywords: aaron_tester
: 4292 4644 (view as bug list)
Depends on: 4417
Blocks: 4598
  Show dependency treegraph
 
Reported: 2011-06-20 14:54 CEST by Pierre Ossman
Modified: 2013-05-15 14:10 CEST (History)
1 user (show)

See Also:
Acceptance Criteria:


Attachments

Description Pierre Ossman cendio 2011-06-20 14:54:13 CEST
gnome-shell currently refuses to start without hardware acceleration, but I forced it on with the new llvmpipe on Fedora 15 and the performance was quite adequate. There were a bunch of graphics bugs, but those could be Xvnc issues.

It might be worthwhile to fix up the final things so that we can offer gnome-shell to our users. Upstream is probably not going to bother.
Comment 1 Pierre Ossman cendio 2011-11-04 10:46:56 CET
It should now work fine with the latest llvmpipe:

http://www.happyassassin.net/2011/11/03/fedora-16-is-gold-but-more-importantly/
Comment 3 Peter Åstrand cendio 2012-03-05 14:59:09 CET
When GNOME Shell runs fine, we should probably also add a separate profile for it. (This was earlier part of bug 4226.)
Comment 4 Pierre Ossman cendio 2012-05-15 10:26:34 CEST
*** Bug 4292 has been marked as a duplicate of this bug. ***
Comment 5 Aaron Sowry cendio 2012-06-29 16:24:04 CEST
(In reply to comment #1)
> It should now work fine with the latest llvmpipe:

Should, but doesn't (F17). It seems that mutter has some problem starting on our Xvnc.

See https://bugzilla.redhat.com/show_bug.cgi?id=836565
Comment 6 Peter Åstrand cendio 2013-03-26 13:03:55 CET
See also https://bugzilla.redhat.com/show_bug.cgi?id=896648
Comment 7 Pierre Ossman cendio 2013-04-16 14:21:23 CEST
Works like a charm with our new upgraded Xvnc! Tested on Fedora 18. Performance is surprisingly good.
Comment 8 Pierre Ossman cendio 2013-05-06 11:26:41 CEST
Broken in Fedora 19 Alpha:

https://bugzilla.redhat.com/show_bug.cgi?id=959941
Comment 9 Pierre Ossman cendio 2013-05-06 13:07:02 CEST
(In reply to comment #8)
> Broken in Fedora 19 Alpha:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=959941

Reopening bug as this seems to be partly our fault.

gnome-shell crashes when it tries to retrieve the current session (a systemd thing). It expects the environment variable XDG_SESSION_ID to be set, but it is not in ThinLinc. This is supposed to be set by pam_systemd.so. The reason it fails is because PAM has a convoluted way of changing the environment, and tl-session isn't handling this.
Comment 10 Pierre Ossman cendio 2013-05-06 13:08:00 CEST
As a side note, the above could also explain why the locking screen didn't work right in Fedora 18.
Comment 11 Pierre Ossman cendio 2013-05-06 14:32:44 CEST
(In reply to comment #9)
> gnome-shell crashes when it tries to retrieve the current session (a systemd
> thing). It expects the environment variable XDG_SESSION_ID to be set, but it is
> not in ThinLinc. This is supposed to be set by pam_systemd.so. The reason it
> fails is because PAM has a convoluted way of changing the environment, and
> tl-session isn't handling this.

Fixed in r27317.
Comment 12 Peter Åstrand cendio 2013-05-14 19:08:22 CEST
*** Bug 4644 has been marked as a duplicate of this bug. ***
Comment 13 Aaron Sowry cendio 2013-05-15 14:10:04 CEST
Works like a charm on Ubuntu 13.04 (see bug #4644). Closing.

Note You need to log in before you can comment on or make changes to this bug.