www.cendio.com
Bug 3998 - tlstunnel should listen for non-TLS traffic instead of catching handshake errors
: tlstunnel should listen for non-TLS traffic instead of catching handshake errors
Status: CLOSED DUPLICATE of bug 4580
: ThinLinc
Misc
: 3.2.0
: PC Unknown
: P2 Enhancement
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-09-22 16:03 by
Modified: 2014-03-17 13:42 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2011-09-22 16:03:29
We're currently trying to handshake for TLS, and when that fails with
GNUTLS_E_UNEXPECTED_PACKET errors, we redirect to HTTPS. A better solution
would perhaps be to actually check the request for the TLS signature bytes,
avoiding the handshake, and redirecting when we don't encounter them.
------- Comment #1 From cendio 2014-02-27 13:39:55 -------

*** This bug has been marked as a duplicate of bug 4580 ***