www.cendio.com
Bug 4111 - Current screen size is still wrong if you change the display resolution
: Current screen size is still wrong if you change the display resolution
Status: CLOSED FIXED
: ThinLinc
Client
: 3.2.0
: PC Unknown
: P2 Normal
: 4.0.0
Assigned To:
:
:
: 3762
: 3968
  Show dependency treegraph
 
Reported: 2011-12-21 13:13 by
Modified: 2012-11-28 12:20 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2011-12-21 13:13:30
This is bug 3762, again. It turns out that we actually broke this functionality
*after* we tested & closed this bug. Most of the pieces are there. However,
probably the fixes to screen_xywh broke it. It's broken both on TLCOS/Linux and
Windows. 

This is an important bug due to how TLCOS/tlcontrol works: If you have a bigger
screen size than selected, the X server will start up with, say 1024. Then
tlclient changes to, say, 800. If you then login, tlclient will create a
session which is 1024 pixels wide. You can also see that the login window is
not centered. 

screen_xywh needs a rewrite!
------- Comment #1 From cendio 2012-06-14 09:29:44 -------
http://www.fltk.org/str.php?L2855
------- Comment #2 From cendio 2012-06-19 14:13:15 -------
Upstream accepted our patch. r25337 also simplifies things; we do not need to
call XRRUpdateConfiguration ourselves. Will be fixed with new FLTK packages,
arriving in minutes. Time reporting will be done on bug 4229.
------- Comment #3 From cendio 2012-10-03 12:38:54 -------
Verified working on Linux/Windows using ThinLinc build 3668,
only need to test TLCOS.
------- Comment #4 From cendio 2012-10-03 14:22:57 -------
(In reply to comment #3)
> Verified working on Linux/Windows using ThinLinc build 3668,
> only need to test TLCOS.

This was an invalid test, the test was redone on linux the correct 
way and it seems to work.

However, it fails on TLCOS running in a virtual machine starting x
with 1024x768 change to 800x600 using controlpanel and then connect
the remote session size becomes 1024x768.
Test using each following alternative 'Current Monitor', 'All monitors' 
and 'Work area'
------- Comment #5 From cendio 2012-10-04 09:38:54 -------
> However, it fails on TLCOS running in a virtual machine starting x
> with 1024x768 change to 800x600 using controlpanel and then connect
> the remote session size becomes 1024x768.
> Test using each following alternative 'Current Monitor', 'All monitors' 
> and 'Work area'

Problem found. FLTK does dlopen("libXrandr.so"), but this lib is typically only
present if you have libXrandr-devel installed. I think we should dlopen
"libXrandr.so.2" instead.
------- Comment #6 From cendio 2012-10-04 10:06:26 -------
(In reply to comment #5)
> > However, it fails on TLCOS running in a virtual machine starting x
> > with 1024x768 change to 800x600 using controlpanel and then connect
> > the remote session size becomes 1024x768.
> > Test using each following alternative 'Current Monitor', 'All monitors' 
> > and 'Work area'
> 
> Problem found. FLTK does dlopen("libXrandr.so"), but this lib is typically only
> present if you have libXrandr-devel installed. I think we should dlopen
> "libXrandr.so.2" instead.

Fixed in cenbuild r25954. Next build should work.
------- Comment #7 From cendio 2012-10-09 10:30:47 -------
I have now tested with TLCOS build 3672 and the issue is fixed.