www.cendio.com
Bug 4145 - SeamlessRDP mouse/window positions gets out of sync on 64 bit systems
: SeamlessRDP mouse/window positions gets out of sync on 64 bit systems
Status: CLOSED FIXED
: ThinLinc
rdesktop
: 3.2.0
: PC Unknown
: P2 Normal
: 4.1.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-01-17 11:44 by
Modified: 2013-10-24 10:49 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-01-17 11:44:11
We have seen cases where apparently the mouse/window position in SeamlessRDP
gets out of sync. I can reproduce this every time on the demo system by running
Excel and using the Windows buttons for minimize/maximize/restore. Probably the
cause of issue12949 as well.
------- Comment #2 From cendio 2013-07-02 10:31:27 -------
We will have a quick look at this to see if it's easily solved.
------- Comment #3 From cendio 2013-09-16 13:35:07 -------
I'm able to reproduce this on a virtual machine with Windows 2003 R2, using
Wordpad. The TL server is running on my workstation, and is the latest nightly
build 4085, using XFCE DE:

Assuming Wordpad was running non-maximized the last time you ran it:

Start Wordpad. Press the maximize button. Now, Wordpad will use the entire
screen area, but will NOT be maximized. If you press the maximize button a
SECOND time, it will be maximized for real, but then the coords are out of
sync.
------- Comment #4 From cendio 2013-09-16 16:37:29 -------
Oh. This is a 64 bit only problem. Most likely, we are not doing the
XGetWindowProperty voodoo correctly in ewmhints.c.
------- Comment #5 From cendio 2013-09-17 15:15:26 -------
This problem should now be solved upstream, and brought to trunk in 27897.
------- Comment #6 From cendio 2013-09-17 15:16:42 -------
*** Bug 2818 has been marked as a duplicate of this bug. ***
------- Comment #7 From cendio 2013-10-17 16:27:06 -------
(In reply to comment #3)
> Start Wordpad. Press the maximize button. Now, Wordpad will use the entire
> screen area, but will NOT be maximized. If you press the maximize button a
> SECOND time, it will be maximized for real, but then the coords are out of
> sync.

Can't reproduce with: 

 - ThinLinc 4.1.1post-4110.
 - Ubuntu 12.04 w/ Unity2D
 - Windows 2003R2 x64.

Good enough for me.