Currently we have a base requirement of Python 2.3. Maybe it is time to raise this requirement, as the distributions in use today have newer versions.
RHEL 5 uses 2.4.3, so Python 2.4 might be a decent new base level.
We've also sort-of required Python 2.4 for a while on accident. It turns out that tlinstaller.py uses the system's subprocess module. This didn't appear until 2.4 though. So since nobody has complained, it would seem that no customer runs anything older.
Bug 2574 covers the last time we raised the base requirement.
Might look for things we can now change/remove as part of this, but should add separate bugs for the things that are found.
Checked a few distros, according to distrowatch.com:
* OpenSuse got 2.4 back in OpenSuse 9.3(!)
* SLE 10-SP3 has 2.4
* RHEL 5.7 has 2.4.3
* Ubuntu got 2.4.1 back in 5.04 hoary.
* Debian 4.0 has 2.4.4
So, requiring 2.4.0 or later shouldn't be a problem.
Fixed in 25589.
I don't think it makes sense to rewrite workarounds for Python < 2.4; that would only take time and potentially introduce problems.
Looks okay. There's a handler for Python 2.3 peculiarities on Solaris 8 in vsmxmlrpccall.py, but I don't think it's hurting anyone if we leave it there. Also, some of our autotests still use mktemp (deprecated in Python 2.4), but this doesn't have anything to do with the product itself really.
There are probably some syntax changes which could be made for efficiency/prettiness, but that would be a lot of work for little gain. Closing.