www.cendio.com
Bug 4242 - Windows client sometimes hangs when connecting to agent
: Windows client sometimes hangs when connecting to agent
Status: CLOSED FIXED
: ThinLinc
Client platforms
: 3.2.0
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-03-28 12:36 by
Modified: 2013-05-22 16:31 (History)


Attachments
tlclient.log (1.96 KB, text/plain)
2012-03-28 12:37, Peter Åstrand
Details
tlclient.log when it works (4.82 KB, text/plain)
2012-03-28 12:48, Peter Åstrand
Details
tlclient.log when using smart card login (2.41 KB, text/plain)
2012-05-15 14:47, Peter Åstrand
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-03-28 12:36:41
Tried latest Windows client against our demo system, hanged when connecting to
the agent. It seems like the thinlinc-login output was intermixed with the
COMMAND_EXITSTATUS, see attached log.
------- Comment #1 From cendio 2012-03-28 12:37:03 -------
Created an attachment (id=432) [details]
tlclient.log
------- Comment #2 From cendio 2012-03-28 12:48:07 -------
Created an attachment (id=433) [details]
tlclient.log when it works

Note that for the successful case, there's no output from thinlinc-login at
all.
------- Comment #3 From cendio 2012-04-03 10:21:58 -------
First test to see how common this is. Test on several windows machines, and
possibly against different servers.

Nightly build of the client needs to be used.
------- Comment #4 From cendio 2012-04-23 11:18:20 -------
Have attempted to reproduce this on Windows 7 and the XP machine in the lab -
could not reproduce. Perhaps we should test again quickly on Peter's laptop
before closing.
------- Comment #5 From cendio 2012-04-26 13:25:57 -------
More testing on my laptop, with build 3459. Seems to be rare. I tried 20 logins
against different servers, sometimes reconnect, sometimes new session. In some
cases, doing a file transfer against the same server. The result is:

No output from thinlinc-login: 12

Only HELLO: 1

Everything from thinlinc-login (ie unsupported service): 7

Intermixed, ie this bug: 0

IOW, we can probably pretend this bug does not exist right now.
------- Comment #6 From cendio 2012-05-15 14:47:44 -------
Created an attachment (id=442) [details]
tlclient.log when using smart card login

Unfortunately, this bug happened again today, when using smart card auth
against the demo system.
------- Comment #7 From cendio 2013-01-10 13:41:07 -------
Will look at this whilst doing bug 3183.
------- Comment #8 From cendio 2013-03-13 16:26:12 -------
This could in theory happen with OpenSSH as well. Seeing if things can be
improved.
------- Comment #9 From cendio 2013-03-13 16:34:54 -------
Fixed in r26792.

Tester could verify this with a malicious thinlinc-login that omits the last
\n.
------- Comment #10 From cendio 2013-05-22 16:31:22 -------
Tried but failed to reproduce the problem with the 4.0 client; does not happen
neither with my laptop against the demo system, neither with a malicious
thinlinc-login. Anyway, the latest nightly build works fine as well, so
assuming we do not see this elsewhere this test period, I'd say this problem is
gone.