www.cendio.com
Bug 4352 - Consider removing VDI support from ThinLinc
: Consider removing VDI support from ThinLinc
Status: CLOSED FIXED
: ThinLinc
| VDI (deprecated)
: 3.4.0
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-06-26 10:27 by
Modified: 2014-05-12 14:03 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-06-26 10:27:27
The current VDI implementation is stagnant, unmaintained and untested. It seems
unlikely that we will be spending any time on this in future either, since we
don't believe it is a viable platform for our target user groups. Perhaps it's
time to lay our cards on the table and remove VDI support from ThinLinc
------- Comment #1 From cendio 2013-09-04 15:07:11 -------
As part of this we should back out the changes done in bug 3041, as well as
stop listing "client" versions of Windows as supported RDP servers.
------- Comment #2 From cendio 2014-02-11 12:59:24 -------
* Remove use of configuration keys in appservergroup.hconf
 - /appservergroups/rdp/<appgroup>/poolname
 - /appservergroups/rdp/<appgroup>/managed_virtual

* Remove use of /vdi/ configuration keys (vdi.hconf)
* Remove tl-vdi-tool
* Remove tl-vdi-physical
* Remove vdi stanza in profiles.hconf.in
* Remove tl-clone-prep
* Remove VDI support in tl-run-rdesktop
* Remove VDI from tlwebadm
* Remove VDI from documentation
------- Comment #3 From cendio 2014-02-12 10:38:49 -------
(In reply to comment #2)
> * Remove VDI support in tl-run-rdesktop
Commit 28403 removes handling of managed_virtual and a rewrite of rdesktop
return code handling...
------- Comment #4 From cendio 2014-02-12 10:44:31 -------
* Remove VDI from build and shipping in tlmisc
------- Comment #5 From cendio 2014-02-12 10:57:41 -------
(In reply to comment #2)
> * Remove vdi stanza in profiles.hconf.in
Fixed in commit r28406
------- Comment #6 From cendio 2014-02-12 11:00:13 -------
(In reply to comment #4)
* Remove VDI from build and shipping in tlmisc
Fixed in commit r28407
------- Comment #7 From cendio 2014-02-12 11:03:56 -------
* Update open source licenses
------- Comment #8 From cendio 2014-02-12 11:07:08 -------
(In reply to comment #2)
> * Remove tl-vdi-tool
Commit r28408 deletes tlmisc/vdi from source tree.
------- Comment #9 From cendio 2014-02-12 11:11:39 -------
(In reply to comment #2)
> * Remove use of configuration keys in appservergroup.hconf
>  - /appservergroups/rdp/<appgroup>/poolname
>  - /appservergroups/rdp/<appgroup>/managed_virtual
> 
Commit 28410 removes VDI stanza and the use of the configuration keys.
------- Comment #10 From cendio 2014-02-12 11:14:59 -------
* Remove VDI support from tl-run-unixapp
In commit 28404 & 28405 the use of managed_virtual/tl-vdi-tool is removed
------- Comment #11 From cendio 2014-02-12 11:21:41 -------
(In reply to comment #5)
> (In reply to comment #2)
> > * Remove vdi stanza in profiles.hconf.in
> Fixed in commit r28406

Commit r28411 remove the use of stanza in order configuration.
------- Comment #12 From cendio 2014-02-12 11:25:48 -------
(In reply to comment #3)
> (In reply to comment #2)
> > * Remove VDI support in tl-run-rdesktop
> Commit 28403 removes handling of managed_virtual and a rewrite of rdesktop
> return code handling...

Verify if we needs to update the progress indications.
------- Comment #13 From cendio 2014-02-12 11:39:37 -------
* Remove ZSI which is only used by vdi framwork
------- Comment #14 From cendio 2014-02-12 11:45:47 -------
(In reply to comment #2)
> * Remove VDI from tlwebadm
Commit 28412 removes build and ship of VDI in tlwebadm and commit 28413 removes
the file from source tree.
------- Comment #15 From cendio 2014-02-12 12:23:25 -------
(In reply to comment #14)
> (In reply to comment #2)
> > * Remove VDI from tlwebadm
> Commit 28412 removes build and ship of VDI in tlwebadm and commit 28413 removes
> the file from source tree.

Commit 28414 removes unused write() function which was only used by VDI parts
removed in previous commits.
------- Comment #16 From cendio 2014-02-12 12:39:24 -------
(In reply to comment #13)
> * Remove ZSI which is only used by vdi framwork

Commit r28415 removes ZSI module from build/ship and open source licenses.
------- Comment #17 From cendio 2014-02-12 12:58:56 -------
(In reply to comment #2)
> * Remove VDI from documentation

ThinLinc Administators Guide is updated in commit r28416.
------- Comment #18 From cendio 2014-02-12 14:46:32 -------
(In reply to comment #12)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > * Remove VDI support in tl-run-rdesktop
> > Commit 28403 removes handling of managed_virtual and a rewrite of rdesktop
> > return code handling...
> 
> Verify if we needs to update the progress indications.

Bug 4988 was added to rework the progress bar into something more useful.
------- Comment #19 From cendio 2014-02-12 16:01:58 -------
(In reply to comment #16)
> (In reply to comment #13)
> > * Remove ZSI which is only used by vdi framwork
> 
> Commit r28415 removes ZSI module from build/ship and open source licenses.

Commit 28419 removes ZSI reference from doc/internal/components.txt
------- Comment #20 From cendio 2014-02-12 16:47:33 -------
(In reply to comment #6)
> (In reply to comment #4)
> * Remove VDI from build and shipping in tlmisc
> Fixed in commit r28407

Commit 28421 removes missed vdi.hconf from spec file.
------- Comment #21 From cendio 2014-02-14 08:13:34 -------
(In reply to comment #2)
> * Remove tl-clone-prep

tlcloneprep was removed from source tree in commit 28426. The build and ship of
tlcloneprep was removed on bug #4486 (comment #10)
------- Comment #22 From cendio 2014-02-17 09:20:30 -------
Autotests fails when testing against removed VDI files.
------- Comment #23 From cendio 2014-02-17 09:22:44 -------
(In reply to comment #22)
> Autotests fails when testing against removed VDI files.

Fixed in commit r28439.
------- Comment #24 From cendio 2014-03-14 09:09:07 -------
tlwebadm is still restarted twice by tl-setup, which was a hack to work around
problems caused by VDI support.
------- Comment #25 From cendio 2014-03-14 09:12:37 -------
(In reply to comment #1)
> As part of this we should back out the changes done in bug 3041, as well as
> stop listing "client" versions of Windows as supported RDP servers.

This is also not fixed.
------- Comment #26 From cendio 2014-03-14 10:15:14 -------
(In reply to comment #24)
> tlwebadm is still restarted twice by tl-setup, which was a hack to work around
> problems caused by VDI support.

Fixed in commit 28619.
------- Comment #27 From cendio 2014-03-14 11:28:41 -------
(In reply to comment #25)
> (In reply to comment #1)
> > As part of this we should back out the changes done in bug 3041, as well as
> > stop listing "client" versions of Windows as supported RDP servers.
> 
> This is also not fixed.

- Commit 28620 removes novelluser_reconnect from tl-run-rdesktop
- Commit 28621 removes novelluser_reconnect from the documentation
- Commit 28622 removes novelluser_reconnect from shipped appserver.hconf
- Commit 28623 removes novelluser_reconnect from tlwebadm
------- Comment #28 From cendio 2014-03-14 12:25:05 -------
(In reply to comment #25)
> (In reply to comment #1)
> > As part of this we should back out the changes done in bug 3041, as well as
> > stop listing "client" versions of Windows as supported RDP servers.
> 
> This is also not fixed.

Commit 28624 removes the windows client versions from RDP server requirments.
------- Comment #29 From cendio 2014-03-24 14:05:21 -------
Time for nitpicking. Found a few stray references to VDI/ZSI.

> buildtools/bin/copyright-missing:80: -a -not -path './tlmisc/vdi/VimService_services.py' \
> buildtools/bin/copyright-missing:81: -a -not -path './tlmisc/vdi/VimService_services_types.py' \
> buildtools/bin/copyright-missing:92: -a -not -path './tlmisc/ZSI/*' \

> autotests/installedtree/test_installedfiles.py:386:            "/opt/thinlinc/modules/ZSI/",
> autotests/installedtree/test_installedfiles.py:462:            "/opt/thinlinc/modules/ZSI"]

tlwebaccess still has some code that claims it's only used by the VDI module.

> webaccess/tlwebaccess-369-    def write(self, data, response=200, headers={}):
> webaccess/tlwebaccess:370:        # FIXME: This is only used by the VDI module
> webaccess/tlwebaccess-371-        self._write(response, headers, data)

The appservergroup tlwebadm module checks for presence of poolname,
which was only used with VMware VDI.

> tladm/modules/thinlinc/tlwebadm/appservers.py:101:            poolname = folder.get_string("poolname")
> tladm/modules/thinlinc/tlwebadm/appservers.py:102:            if poolname:
> tladm/modules/thinlinc/tlwebadm/appservers.py-103-                # Not editable.
> tladm/modules/thinlinc/tlwebadm/appservers.py-104-                editable = False
> tladm/modules/thinlinc/tlwebadm/appservers.py-105-            else:
> tladm/modules/thinlinc/tlwebadm/appservers.py-106-                editable = True


VDI is still mentioned in the white paper, so I am marking the
update-whitepaper bug as a dependency for this bug.
------- Comment #30 From cendio 2014-03-24 15:59:58 -------
(In reply to comment #29)
> Time for nitpicking. Found a few stray references to VDI/ZSI.
> 
> > buildtools/bin/copyright-missing:80: -a -not -path './tlmisc/vdi/VimService_services.py' \
> > buildtools/bin/copyright-missing:81: -a -not -path './tlmisc/vdi/VimService_services_types.py' \
> > buildtools/bin/copyright-missing:92: -a -not -path './tlmisc/ZSI/*' \
>

Fixed in commit 28703.


> > autotests/installedtree/test_installedfiles.py:386:            "/opt/thinlinc/modules/ZSI/",
> > autotests/installedtree/test_installedfiles.py:462:            "/opt/thinlinc/modules/ZSI"]
>

Fixed in commit 28704.

> tlwebaccess still has some code that claims it's only used by the VDI module.
> 
> > webaccess/tlwebaccess-369-    def write(self, data, response=200, headers={}):
> > webaccess/tlwebaccess:370:        # FIXME: This is only used by the VDI module
> > webaccess/tlwebaccess-371-        self._write(response, headers, data)
> 

This was removed in tlwebadm in commit r28414. Fixed in commit 28705.

> The appservergroup tlwebadm module checks for presence of poolname,
> which was only used with VMware VDI.
> 
> > tladm/modules/thinlinc/tlwebadm/appservers.py:101:            poolname = folder.get_string("poolname")
> > tladm/modules/thinlinc/tlwebadm/appservers.py:102:            if poolname:
> > tladm/modules/thinlinc/tlwebadm/appservers.py-103-                # Not editable.
> > tladm/modules/thinlinc/tlwebadm/appservers.py-104-                editable = False
> > tladm/modules/thinlinc/tlwebadm/appservers.py-105-            else:
> > tladm/modules/thinlinc/tlwebadm/appservers.py-106-                editable = True
> 
>

Fixed in commit r28706.
------- Comment #31 From cendio 2014-03-24 16:04:26 -------
> VDI is still mentioned in the white paper, so I am marking the
> update-whitepaper bug as a dependency for this bug.

Fixed in commit 28707.
------- Comment #32 From cendio 2014-03-26 09:23:19 -------
(In reply to comment #2)
> * Remove tl-vdi-physical

vdi-physical is still around.
------- Comment #33 From cendio 2014-03-26 11:20:00 -------
(In reply to comment #32)
> (In reply to comment #2)
> > * Remove tl-vdi-physical
> 
> vdi-physical is still around.

Fixed in commit 28721.
------- Comment #34 From cendio 2014-03-28 09:33:09 -------
There's still a page about VDI on the homepage:

http://www.cendio.com/products/thinlinc/solutions/technology/vdibroker.xhtml
------- Comment #35 From cendio 2014-03-28 10:54:31 -------
(In reply to comment #34)
> There's still a page about VDI on the homepage:
> 
> http://www.cendio.com/products/thinlinc/solutions/technology/vdibroker.xhtml

Fixed in commit 28747.
------- Comment #36 From cendio 2014-03-28 11:47:01 -------
I can't find anything VDI still in the product. There's some references to VDI
left in the news archives on the web, but that's OK with me.
------- Comment #37 From cendio 2014-04-02 09:54:46 -------
The VMware Horizon View Client for Linux is available in at least Ubuntu 12.04.
Starts OK in a TL session, although I do not have a Horizon View server to
connect to at this point.
------- Comment #38 From cendio 2014-04-14 09:59:27 -------
Windows XP screen shot still present.
------- Comment #39 From cendio 2014-04-14 16:10:39 -------
(In reply to comment #38)
> Windows XP screen shot still present.

Fixed in commit 28845.
------- Comment #40 From cendio 2014-04-16 10:44:00 -------
(In reply to comment #39)
> (In reply to comment #38)
> > Windows XP screen shot still present.
> 
> Fixed in commit 28845.

XP screenshot is gone.
------- Comment #41 From cendio 2014-04-17 13:36:19 -------
There is JavaScript stuff that only VDI used left in tlwebadm.
------- Comment #42 From cendio 2014-04-23 14:38:45 -------
(In reply to comment #41)
> There is JavaScript stuff that only VDI used left in tlwebadm.

javscripts removed in commit 28912.
------- Comment #43 From cendio 2014-04-24 12:23:20 -------
(In reply to comment #42)
> (In reply to comment #41)
> > There is JavaScript stuff that only VDI used left in tlwebadm.
> 
> javscripts removed in commit 28912.

removed references to javascripts from makefile in commit 28915.
------- Comment #44 From cendio 2014-04-28 14:01:18 -------
(In reply to comment #43)
> (In reply to comment #42)
> > (In reply to comment #41)
> > > There is JavaScript stuff that only VDI used left in tlwebadm.
> > 
> > javscripts removed in commit 28912.
> 
> removed references to javascripts from makefile in commit 28915.

Looks OK, couldn't find anything still referencing the javascripts in tlwebadm.
------- Comment #45 From cendio 2014-05-12 14:03:16 -------
Minor update in 28969:
Don't mention Windows XP in tlsnd context.