www.cendio.com
Bug 4353 - Client support for Windows 8 and 2012
: Client support for Windows 8 and 2012
Status: CLOSED FIXED
: ThinLinc
Client platforms
: 3.4.0
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
: 4587 4588
:
  Show dependency treegraph
 
Reported: 2012-06-27 12:17 by
Modified: 2013-05-31 13:03 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-06-27 12:17:21
Windows 8 is expected in Juli, ie possibly only a few days away. We need to
test how the TL client works on this platform, and eventually probably also
make it an officially supported platform. Probably also buy a machine with
Windows 8.
------- Comment #1 From cendio 2012-07-31 15:40:23 -------
Actually, the release date is announced to October 26 2012:

http://windowsteamblog.com/windows/b/bloggingwindows/archive/2012/07/18/windows-8-will-be-available-on.aspx

We cannot wait for this; moving to next release.
------- Comment #3 From cendio 2012-11-20 11:45:14 -------
Order a machine for this.
------- Comment #4 From cendio 2012-11-21 12:47:32 -------
We should also test with Norton antivirus, see issue 13848.
------- Comment #6 From cendio 2013-04-12 14:39:29 -------
Updating time estimation.
------- Comment #7 From cendio 2013-04-16 11:04:57 -------
Everything seems to work. We're not doing the sound thing and it was not
strictly speaking a Windows 8 problem so I removed it from the "depends on"
list.
------- Comment #8 From cendio 2013-05-15 09:10:39 -------
*** Bug 4588 has been marked as a duplicate of this bug. ***
------- Comment #9 From cendio 2013-05-31 10:48:55 -------
(to clarify: the sound thing refered to in comment #7 is bug 2831).
------- Comment #10 From cendio 2013-05-31 12:36:16 -------
I have tested client build 3966 on Win8

Client works as expected when authenticating smartcard.
Note, tested with a SITHS card and it worked out of the box without netid
installed on the Win8 client.

- Audio redirection
  Works as expected except for the issue on bug #2831

- Driver redirection
  Works as expected, tested with special My documents and
  copying/deleting creating files

- Printer redirection
  Works as expected, with and without option for displaying local
  printer selection dialog.

- Smartcard redirection
  Works as expected

- Serial redirection
  Failed to test this due to lack of win8 drivers for our specific usb->ser
  cabel GUC232A, this one is old... we should definitly get a new one.
------- Comment #11 From cendio 2013-05-31 12:48:13 -------
Basic tests has be done installing and running client build 3966 on windows
server 2012. I didnt stumble upon any oddities however, sound and smartcard
redirection was not tested.
------- Comment #12 From cendio 2013-05-31 12:48:45 -------
(In reply to comment #10)
> I have tested client build 3966 on Win8
> 
> Client works as expected when authenticating smartcard.
> Note, tested with a SITHS card and it worked out of the box without netid
> installed on the Win8 client.
> 
> - Audio redirection
>   Works as expected except for the issue on bug #2831
> 
> - Driver redirection
>   Works as expected, tested with special My documents and
>   copying/deleting creating files
> 
> - Printer redirection
>   Works as expected, with and without option for displaying local
>   printer selection dialog.
> 
> - Smartcard redirection
>   Works as expected
> 
> - Serial redirection
>   Failed to test this due to lack of win8 drivers for our specific usb->ser
>   cabel GUC232A, this one is old... we should definitly get a new one.

There was no problem with the installer while installing the client.