www.cendio.com
Bug 4368 - 3.4.0 client crashed upon logout on Mac OS X 10.8
: 3.4.0 client crashed upon logout on Mac OS X 10.8
Status: CLOSED FIXED
: ThinLinc
Client platforms
: 3.4.0
: PC Unknown
: P2 Normal
: 4.0.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-08-07 14:37 by
Modified: 2012-11-28 12:38 (History)


Attachments
Apple debug info (33.58 KB, text/plain)
2012-08-07 14:38, Peter Åstrand
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-08-07 14:37:33
As the summary says. See attachement.
------- Comment #1 From cendio 2012-08-07 14:38:30 -------
Created an attachment (id=448) [details]
Apple debug info
------- Comment #2 From cendio 2012-08-21 13:02:10 -------
The problem is this line in tlclient:

            AEDisposeDesc(&focusVNCViewer);

If it is commented out, the crash disappears. One would think that that
function is used for disposing an AEDesc, but apparently, it is used for
disposing other objects as well, including AppleEvent:s. And as usual, the
reference documentation for AEDisposeDesc is missing...
------- Comment #3 From cendio 2012-08-22 09:47:12 -------
Fixed in 25632.
------- Comment #4 From cendio 2012-08-22 09:54:26 -------
termVNC rewritten in 25633.
------- Comment #5 From cendio 2012-10-01 10:18:49 -------
Tested with client build 3668 on Mac OSX 10.8.1 and no crashes occurs 
at logout.