www.cendio.com
Bug 4462 - tl-set-sso-helper can hang, consumes all available CPU resources
: tl-set-sso-helper can hang, consumes all available CPU resources
Status: CLOSED FIXED
: ThinLinc
Other
: 3.4.0
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-11-07 11:17 by
Modified: 2013-05-21 16:18 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-11-07 11:17:16
Noticed on the demo system with the recent invasion of mass-registered users.

-bash-3.2$ ps -ef | grep tl-set[-]
yahomahd  3790  3784 92 Nov06 ?        14:58:39 python-thinlinc
libexec/tl-set-sso-helper
mohm3l-n  7049  7041 92 Nov06 ?        14:50:45 python-thinlinc
libexec/tl-set-sso-helper
mohmissa 11636 11630 93 Nov06 ?        13:27:15 python-thinlinc
libexec/tl-set-sso-helper
yopmwasa 12629     1 89 Nov06 ?        14:07:06 python-thinlinc
libexec/tl-set-sso-helper
rtrto321 12936 12930 93 Nov06 ?        17:56:32 python-thinlinc
libexec/tl-set-sso-helper
mohmxxx  15059 15051 88 Nov06 ?        10:47:18 python-thinlinc
libexec/tl-set-sso-helper
mailmla_ 19904 19893 80 10:30 ?        00:34:32 python-thinlinc
libexec/tl-set-sso-helper
yopmwasa 24172     1 91 Nov06 ?        15:17:24 python-thinlinc
libexec/tl-set-sso-helper
hotmscct 25630 25622 91 00:42 ?        09:36:30 python-thinlinc
libexec/tl-set-sso-helper

The processes doesn't seem to actually do anything though.

[root@bard ~]# strace -f -p 3790
Process 3790 attached - interrupt to quit
^C
Process 3790 detached
------- Comment #1 From cendio 2012-11-20 11:51:31 -------
*** Bug 4463 has been marked as a duplicate of this bug. ***
------- Comment #2 From cendio 2013-03-14 10:41:54 -------
Fixed in r26799.
------- Comment #3 From cendio 2013-05-21 16:18:37 -------
Code inspected.