www.cendio.com
Bug 4465 - Include window manager and helper scripts for solitary application publishing
: Include window manager and helper scripts for solitary application publishing
Status: CLOSED FIXED
: ThinLinc
Other
: 3.4.0
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
:
: 38 4513
  Show dependency treegraph
 
Reported: 2012-11-08 10:15 by
Modified: 2013-06-27 14:07 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-11-08 10:15:42
Split off from bug 38 and Issue 13649. To make it easier to publish a single
application in TL, we should include a suitable Window manager and helper
scripts for this. In practice, I think this will mean bundling MatchBox. We
will need to fix the 64-bit bug though, see
https://bugzilla.redhat.com/show_bug.cgi?id=758233.
------- Comment #1 From cendio 2012-12-11 11:48:32 -------
We have settled for OpenBox instead.
------- Comment #2 From cendio 2012-12-14 10:08:18 -------
(In reply to comment #1)
> We have settled for OpenBox instead.

Could still be interesting to take a look at Enlightenment Illume:
http://wiki.openmoko.org/wiki/Illume
------- Comment #3 From cendio 2013-01-16 09:39:40 -------
Now implemented. Installed on demo system. For testing:

* Check that the OpenBox binary works on all major distributions

* Check that the fallback works if it does not start

* No error messages in session log file

* Documentation

* Try tl-single-app with multiple applications.
------- Comment #4 From cendio 2013-05-28 14:06:35 -------
> * Try tl-single-app with multiple applications.

- Tested firefox with alot of popup windows which worked as expected.

- Tested blender but it seems like openbox fails to resize its window
  while resizing the session.

- Tested with gnome-calulator which has a fixed size windowed, which kind of 
  breaks the "single app" approach
------- Comment #5 From cendio 2013-05-28 15:21:04 -------
(In reply to comment #4)
> - Tested blender but it seems like openbox fails to resize its window
>   while resizing the session.
> 
More testing shows that blender window is not maximized using tl-single-app
and its openbox specific configuration, however without thinlinc specific
openbox configuration blender gets maximized as it should.
------- Comment #6 From cendio 2013-05-28 15:57:41 -------
(In reply to comment #5)
> (In reply to comment #4)
> > - Tested blender but it seems like openbox fails to resize its window
> >   while resizing the session.
> > 
> More testing shows that blender window is not maximized using tl-single-app
> and its openbox specific configuration, however without thinlinc specific
> openbox configuration blender gets maximized as it should.

Does not happen on eudemo. Configured the client to run "tl-single-app vglrun
blender", works perfectly fine. Blame Ubuntu?
------- Comment #7 From cendio 2013-05-29 09:38:58 -------
(In reply to comment #4)
> > * Try tl-single-app with multiple applications.
> 
> - Tested firefox with alot of popup windows which worked as expected.

Good. 

> - Tested blender but it seems like openbox fails to resize its window
>   while resizing the session.

Works on eudemo. 

> - Tested with gnome-calulator which has a fixed size windowed, which kind of 
>   breaks the "single app" approach

Apparently this depends on the version; the version in RHEL5/6 can be resized.
But in any case, we cannot do much about fixed size applications. (Well,
perhaps communicate this to the client, but that would be another bug.) 

Closing this bug - reopen if you think that Blender@Ubuntu is a showstopper.
------- Comment #8 From cendio 2013-05-30 10:49:37 -------
(In reply to comment #3)
> * Check that the fallback works if it does not start

When logging into a new session our shipped openbox is used as initial WM when
showing welcome/xstartup and profile chooser. The fallback here is that we
should continue the logon process without a windows manager if openbox fails to
start which happens after a timeout.

This fallback was verified when openbox failed to launch on SLED11, there was a
timeout waiting for WM and then the logon process continued.
------- Comment #9 From cendio 2013-05-30 10:50:30 -------
(In reply to comment #3)
> * No error messages in session log file
> 

With build 3966 there was no error messages in logfile related to openbox when
testing on Ubuntu 12.05 and SLED 11 Sp2
------- Comment #10 From cendio 2013-05-30 11:16:43 -------
(In reply to comment #3)
> * Try tl-single-app with multiple applications.

Tested running a terminal and gedit and it works as expected, you can switch
between the applications through the titlebar icon popupmenu.

Works as expected with several sessions.
------- Comment #11 From cendio 2013-05-30 11:19:18 -------
If firefox suffered an unexpected close one will be presented with a window for
restoring previous "firefox session", this window is maximized as expected but
when pressing restore the window appears to be closed and a new one is created
minimized. So, i see a blue desktop and need to use context menu to bring the
window back to maximized.
------- Comment #12 From cendio 2013-05-30 13:43:24 -------
(In reply to comment #11)
> If firefox suffered an unexpected close one will be presented with a window for
> restoring previous "firefox session", this window is maximized as expected but
> when pressing restore the window appears to be closed and a new one is created
> minimized. So, i see a blue desktop and need to use context menu to bring the
> window back to maximized.

This was not reproducable on SLED 11 Sp2, nor on demosystem so it might be
something with Ubuntu modification of firefox (unity modifications) that plays
some tricks on us.
------- Comment #13 From cendio 2013-05-30 13:44:21 -------
After alot of testing it shows it works as expected, closing hereby the bug.
------- Comment #14 From cendio 2013-06-26 10:59:36 -------
We have got some reports of that OpenBox does not start until you click in the
background, press a key or similar. I've seen this with "tl-single-app firefox"
in some cases. Now, after upgrading eudemo to 4.1.0rc2, this happens even for
the profile selection dialog. Thus, we need to take a look at this.
------- Comment #15 From cendio 2013-06-26 15:58:46 -------
(In reply to comment #14)
> We have got some reports of that OpenBox does not start until you click in the
> background, press a key or similar. I've seen this with "tl-single-app firefox"
> in some cases. Now, after upgrading eudemo to 4.1.0rc2, this happens even for
> the profile selection dialog. Thus, we need to take a look at this.

https://bugzilla.icculus.org/show_bug.cgi?id=5977
------- Comment #16 From cendio 2013-06-26 17:43:58 -------
(In reply to comment #15)
> (In reply to comment #14)
> > We have got some reports of that OpenBox does not start until you click in the
> > background, press a key or similar. I've seen this with "tl-single-app firefox"
> > in some cases. Now, after upgrading eudemo to 4.1.0rc2, this happens even for
> > the profile selection dialog. Thus, we need to take a look at this.
> 
> https://bugzilla.icculus.org/show_bug.cgi?id=5977

Workaround in 27566.
------- Comment #17 From cendio 2013-06-26 17:50:36 -------
It turns out that OpenBox enumerates all groups at startup. This is slow on
system with a lot of groups. This is done in find_uid_gid. Don't understand
what's wrong with getgroups().
------- Comment #18 From cendio 2013-06-26 17:56:05 -------
(In reply to comment #17)
> It turns out that OpenBox enumerates all groups at startup. This is slow on
> system with a lot of groups. This is done in find_uid_gid. Don't understand
> what's wrong with getgroups().

https://bugzilla.icculus.org/show_bug.cgi?id=5978

Code disabled in 27567.
------- Comment #19 From cendio 2013-06-27 14:07:07 -------
Peter have installed and verified this fix on our demo system which was a good
target for reproducing the race. Works as expected.