Bug 4642 - Resize support for the HTML5 Client
Summary: Resize support for the HTML5 Client
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Web Access (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Enhancement
Target Milestone: 4.1.1
Assignee: Samuel Mannehed
URL:
Keywords: aaron_tester, relnotes
Depends on: 4648
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 12:43 CEST by Peter Åstrand
Modified: 2013-10-28 09:41 CET (History)
2 users (show)

See Also:
Acceptance Criteria:


Attachments
Implements the resize support functionality (4.58 KB, patch)
2013-06-20 15:12 CEST, Samuel Mannehed
Details
fixes some errors in the logic from the first patch (3.52 KB, patch)
2013-06-25 13:18 CEST, Samuel Mannehed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Åstrand cendio 2013-05-13 12:43:39 CEST
Currently, the HTML5 client will adapt its canvas size to the current server side size of the session. Newly created sessions will have a size determined by /vsmagent/default_geometry. 

This is different from how the native client works:

1) It will resize the remote session to the preferred size set by the client side. 

2) If "Resize remote session to the local window" is activated, it will dynamically resize the remote session when the size of the local window is changed. 

We should implement support for both these features in the HTML5 client.
Comment 1 Peter Åstrand cendio 2013-05-16 16:59:14 CEST
> 1) It will resize the remote session to the preferred size set by the client
> side. 

Initial size issue moved to bug 4648.
Comment 2 Henrik Andersson cendio 2013-05-28 09:16:22 CEST
There is a pullrequest upstream for auto scaling feature, it does not fullfill requirements but it could be polished:

https://github.com/kanaka/noVNC/pull/117
Comment 3 Samuel Mannehed cendio 2013-06-20 15:12:06 CEST
Created attachment 478 [details]
Implements the resize support functionality

Fixed in the attached resizesupport.patch
Made a pull request to the noVNC project on github: https://github.com/kanaka/noVNC/pull/271
Comment 4 Samuel Mannehed cendio 2013-06-25 13:18:43 CEST
Created attachment 479 [details]
fixes some errors in the logic from the first patch

I fixed some errors in the logic and some indentation from the first patch.
Also pushed into the same pull request on the noVNC project.
Comment 5 Samuel Mannehed cendio 2013-07-01 14:17:42 CEST
Fixed in revision 27593.
Comment 6 Samuel Mannehed cendio 2013-07-02 15:28:38 CEST
Updated in revision 27600.

Note that my commit-message in revision 27593 is wrong: I wrote "Fixes bug 4648" while it actually fixes this bug, 4642.
Comment 7 Samuel Mannehed cendio 2013-09-06 11:24:56 CEST
There is a problem when trying to resize the viewport on mobile devices, reopening.
Comment 8 Samuel Mannehed cendio 2013-09-12 15:17:19 CEST
Viewport problem fixed in 27874.
Comment 9 Aaron Sowry cendio 2013-10-21 13:55:24 CEST
There is still a slight problem when resizing the session on an iPad:

1) Start a session in landscape mode
2) Rotate screen to portrait, and then back to landscape again

The new landscape session appears to have the correct size, but incorrect alignment - the top of the session is obscured slightly by the top NoVNC bar, and there is a few pixels of blank space at the bottom of the browser.

Re-opening for discussion.
Comment 10 Samuel Mannehed cendio 2013-10-24 13:03:14 CEST
The alignment problem in Safari has nothing to do with this bug, it seems like iOS 7 has introduced a new bug/behavior which is the cause of the alignment problem. Opened bug 4868 for that.
Comment 11 Aaron Sowry cendio 2013-10-28 09:41:42 CET
A new bug has been opened for the Safari bug, so closing.