www.cendio.com
Bug 4644 - Gnome Shell fails to start in a ThinLinc session on Ubuntu 13.04
: Gnome Shell fails to start in a ThinLinc session on Ubuntu 13.04
Status: CLOSED DUPLICATE of bug 3836
: ThinLinc
Server OS
: 4.0.0
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-05-13 16:47 by
Modified: 2013-05-15 14:21 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-05-13 16:47:21
Get a number of errors similar to this in xinit.log:

Window manager warning: Log level 32: Execution of main.js threw exception:
Gio.IOErrorEnum: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError:
Unable to lookup session information for process '13425'
------- Comment #1 From cendio 2013-05-13 17:08:15 -------
I can get a functional Gnome Shell session however, by starting a terminal
session and running the following:

ck-launch-session dbus-launch gnome-session --session=gnome
------- Comment #2 From cendio 2013-05-14 09:29:53 -------
(In reply to comment #1)
> I can get a functional Gnome Shell session however, by starting a terminal
> session and running the following:
> 
> ck-launch-session dbus-launch gnome-session --session=gnome

We already start dbus as part of xstartup.d, so the following will suffice:

ck-launch-session gnome-session --session=gnome

See also bug #3796
------- Comment #3 From cendio 2013-05-14 14:11:01 -------
Found a different approach to this. Ubuntu uses pam_ck_connector, but it isn't
working for us. The reason is that it gets uppity when PAM_TTY isn't set. So if
we fix that, we should get a proper ConsoleKit session.

We also want to set RHOST to make ConsoleKit register the session as remote.
------- Comment #4 From cendio 2013-05-14 14:32:44 -------
Fixed in r27374.
------- Comment #5 From cendio 2013-05-14 19:08:22 -------

*** This bug has been marked as a duplicate of bug 3836 ***