www.cendio.com
Bug 4664 - HTML5 client login form should support saving the username
: HTML5 client login form should support saving the username
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.1.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-05-29 10:05 by
Modified: 2013-10-24 10:56 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-05-29 10:05:54
It could be nice if the HTML5 login form could support saving the username.
Hopefully this can be done with a browser cookie.
------- Comment #1 From cendio 2013-06-04 10:47:12 -------
Most browsers have mechanisms for remembering form values. Shouldn't that work
in this case?
------- Comment #2 From cendio 2013-07-19 14:04:49 -------
I think this bug should be closed. The username (and the password) are
remembered by the browser if cookies are enabled. 

Tested in Google Chrome 29 and Firefox 22.0
------- Comment #3 From cendio 2013-09-24 11:17:02 -------
Might be worth noting that the setting for saving usernames and passwords is
disabled by default in iOS. It works fine if that setting is enabled.
------- Comment #4 From cendio 2013-10-11 17:35:37 -------
There seems to be some problems with saving passwords in both safari and chrome
on iOS 7. I could find many threads about it and I don't think the issue is on
our side. Will keep an eye on it though.
https://discussions.apple.com/thread/5335821?start=0&tstart=0
------- Comment #5 From cendio 2013-10-15 14:55:08 -------
The problem in iOS 7 only comes down to user settings and confusing changes to
the UI in iOS 7. Not a problem on our side.
------- Comment #6 From cendio 2013-10-17 11:38:40 -------
(In reply to comment #2)
> I think this bug should be closed. The username (and the password) are
> remembered by the browser if cookies are enabled. 

I'm not sure I understand. Are we even using cookies?

In iOS 7, it's possible to store passwords even for those sites which request
that they not be saved. In this case, they're added to a kind of keyring which
must be unlocked with a PIN code.

In Firefox 17 however, there's no such feature and therefore it's impossible to
store passwords. Re-opening until we can clarify what the behaviour is supposed
to be.
------- Comment #7 From cendio 2013-10-17 12:50:21 -------
(In reply to comment #6)
> (In reply to comment #2)
> > I think this bug should be closed. The username (and the password) are
> > remembered by the browser if cookies are enabled. 
> 
> I'm not sure I understand. Are we even using cookies?
> 
> In iOS 7, it's possible to store passwords even for those sites which request
> that they not be saved. In this case, they're added to a kind of keyring which
> must be unlocked with a PIN code.
> 
> In Firefox 17 however, there's no such feature and therefore it's impossible to
> store passwords. Re-opening until we can clarify what the behaviour is supposed
> to be.

I think the problem is that we are specifying autocomplete="off" for the
username input field. This was apparently added as a side effect of this
commit:

--
r27730 | samuel | 2013-07-25 16:33:36 +0200 (tor, 25 jul 2013) | 5 lines

Fixes bug 4759.

Added support for extra keys such as Ctrl, Alt, Tab and Esc on mobile devices.
--

This commit touch many files, but also templates/main/home.tmpl where this is
specified. Perhaps this was a mistake?
------- Comment #8 From cendio 2013-10-22 18:36:19 -------
(In reply to comment #7) 
> I think the problem is that we are specifying autocomplete="off" for the
> username input field. This was apparently added as a side effect of this
> commit:
> 
> --
> r27730 | samuel | 2013-07-25 16:33:36 +0200 (tor, 25 jul 2013) | 5 lines
> 
> Fixes bug 4759.
> 
> Added support for extra keys such as Ctrl, Alt, Tab and Esc on mobile devices.
> --
> 
> This commit touch many files, but also templates/main/home.tmpl where this is
> specified. Perhaps this was a mistake?

Fixed in revision 28066.
------- Comment #9 From cendio 2013-10-23 10:08:45 -------
Note that r28066 contains a typo - I have tested with the following patch:

--- trunk/ctc/webaccess/templates/main/home.tmpl    2013-10-22
 01:17:10 UTC (rev 28065)
+++ trunk/ctc/webaccess/templates/main/home.tmpl    2013-10-22
 16:33:18 UTC (rev 28066)
@@ -43,7 +43,7 @@
 #if $new_conversation
     <tr><th align="left">Username:</th>
       <td><input type="text" name="username" value="$qh($username)" autofocus 
-                 autocapitalize="off" autocomplete="off"></td>
+                 autocapitalize="off""></td>
     </tr>
 #else
     <input type="hidden" name="username" value="$qh($username)">

With this patch, I am able to save the username and password in both Safari and
Firefox. Waiting for the typo to be fixed before closing this bug.
------- Comment #10 From cendio 2013-10-23 10:18:11 -------
Typo fixed in r28068
------- Comment #11 From cendio 2013-10-23 10:51:21 -------
(In reply to comment #10)
> Typo fixed in r28068

Great, closing.