www.cendio.com
Bug 4740 - pcsctun's SCardStatus has unreasonable requirements on the ATR buffer
: pcsctun's SCardStatus has unreasonable requirements on the ATR buffer
Status: CLOSED FIXED
: ThinLinc
Smart card
: trunk
: PC Unknown
: P2 Normal
: 4.1.1
Assigned To:
:
:
:
: 4732
  Show dependency treegraph
 
Reported: 2013-07-05 12:32 by
Modified: 2013-10-24 11:01 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-07-05 12:32:43
This is a regression caused by bug 3984. When doing that change, we
inadvertently added the requirement that the ATR buffer must be 33 bytes, when
a 32 byte one will suffice.
------- Comment #1 From cendio 2013-07-05 12:34:13 -------
Fixed in r27612 and r27613.
------- Comment #2 From cendio 2013-10-17 10:15:25 -------
Done several tests:

* Login to Apoteket using BankID+Fribid
* Init PKCS15 card using my pkcs15-selfsigned.sh
* Basic test with NetID for Linux

Tested these combinations:

server        client
=======================
4.1.0        4.1.1win    ok
4.1.0        4.1.1lin    ok
4.1.1        4.1.0win    ok    
4.1.1        4.1.0lin    ok
4.1.1        4.1.1win    ok
4.1.1        4.1.1lin    ok