www.cendio.com
Bug 4765 - Status for vsmagent/vsmserver is "stopped" on systemd systems, even when services are actually running
: Status for vsmagent/vsmserver is "stopped" on systemd systems, even when serv...
Status: CLOSED FIXED
: ThinLinc
Web Administration
: 4.1.0
: PC Unknown
: P2 Normal
: 4.1.1
Assigned To:
:
:
: 4290
:
  Show dependency treegraph
 
Reported: 2013-08-09 11:23 by
Modified: 2013-10-24 11:03 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-08-09 11:23:51
See issue 14443. Tested on F17 using 4.1.0post (build 4031).
------- Comment #1 From cendio 2013-08-09 12:58:32 -------
This is because ctccommon expects SysV-style output from a call to
/etc/init.d/<service>, and what it's getting is systemd-style output.
------- Comment #2 From cendio 2013-08-13 15:44:01 -------
The problem is caused by the service wrapper (that's a fairly new thing).
Instead of looking at the return code, it tries to parse the output.

That wrapper is also a rather pointless abstraction on top of subprocess. So I
think I'll clean things up in the process.
------- Comment #3 From cendio 2013-08-13 16:00:51 -------
Fixed in r27774 to r27776.
------- Comment #4 From cendio 2013-08-22 11:20:19 -------
I found that services wouldn't start from tl-setup. The code was trying to call
the init script with the init script name as the first argument. Bugfixed in
r27798.
------- Comment #5 From cendio 2013-10-01 10:53:43 -------
*** Bug 4818 has been marked as a duplicate of this bug. ***
------- Comment #6 From cendio 2013-10-01 10:54:13 -------
We're getting a traceback in tlwebadm (see bug 4818).
------- Comment #7 From cendio 2013-10-04 09:32:52 -------
(In reply to comment #6)
> We're getting a traceback in tlwebadm (see bug 4818).

Fixed in r27991.
------- Comment #8 From cendio 2013-10-18 13:01:30 -------
Verified on Fedora 19, ThinLinc build 4118 which includes the new service
wrapper script. Service status is shown correctly from both console and web
interface.
There were also no problems to start the service while installing.