www.cendio.com
Bug 4793 - switch to -O2 (and/or -Os) for optimisations
: switch to -O2 (and/or -Os) for optimisations
Status: CLOSED FIXED
: ThinLinc
Other
: trunk
: PC Unknown
: P2 Normal
: 4.5.0
Assigned To:
:
:
:
: 5430
  Show dependency treegraph
 
Reported: 2013-09-05 13:57 by
Modified: 2015-09-25 13:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-09-05 13:57:50
We're currently using -O3 in most of the ThinLinc build. This does not seem to
be a good choice as almost everyone else is using -O2 and -O3 is therefore
poorly tested and buggy. We've had at least one bug cause by this.

See bug 3304 for some more details.
------- Comment #1 From cendio 2013-09-10 16:41:47 -------
Also remember to remove the hack mentioned in bug 4711.
------- Comment #2 From cendio 2013-12-03 10:39:48 -------
*** Bug 4518 has been marked as a duplicate of this bug. ***
------- Comment #3 From cendio 2015-06-22 13:12:03 -------
-O3 breaks compilation of Xorg in a new way with gcc 5.1:

https://bugs.freedesktop.org/show_bug.cgi?id=73089
------- Comment #4 From cendio 2015-06-22 13:54:50 -------
Switched everything over to a common "-Wall -O2 -g" in r30457. Cleaned up
tlclient's Makefile a bit in r30458.
------- Comment #5 From cendio 2015-06-22 13:57:33 -------
(In reply to comment #3)
> -O3 breaks compilation of Xorg in a new way with gcc 5.1:
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=73089

Wrong link. I was supposed to be this one:

https://bugs.freedesktop.org/show_bug.cgi?id=91031
------- Comment #6 From cendio 2015-07-27 13:33:13 -------
(In reply to comment #4)
> Switched everything over to a common "-Wall -O2 -g" in r30457. Cleaned up
> tlclient's Makefile a bit in r30458.

Nothing in our source code refers to -O3, and all client binaries still work.