www.cendio.com
Bug 4846 - Viewport drag / pan does not work in the HTML5 client on touch devices
: Viewport drag / pan does not work in the HTML5 client on touch devices
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: Other Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
: 5352
: 4760
  Show dependency treegraph
 
Reported: 2013-10-11 16:40 by
Modified: 2015-04-24 15:08 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-10-11 16:40:26
Regression caused by revision 27874.
This bug is only noticed when the session size is bigger than browser window,
the viewport, on a touch device and one actives the "hand" option to pan.
To reproduce one has to either disable the automatic resize (on the server
side) or invoke a different resize, such as one by xrandr -s.
------- Comment #1 From cendio 2013-10-14 08:48:19 -------
(In reply to comment #0)
> Regression caused by revision 27874.

Reopen bug 4642 instead?
------- Comment #2 From cendio 2013-12-20 15:31:39 -------
Revert r28261 when fixing this.
------- Comment #3 From cendio 2015-01-23 20:07:28 -------
I have reworked the viewport logic in noVNC to make this work and pushed the
changes to a upstream pullrequest: 

https://github.com/kanaka/noVNC/pull/271

I will give some other noVNC people a few days to review the code before
merging it into noVNC master and before I do the vendordrop for ThinLinc.
------- Comment #6 From cendio 2015-02-11 11:42:31 -------
Fixed in commits 29968 and 29969.

r29968 - vendordrop
r29969 - revert r28261
------- Comment #7 From cendio 2015-02-11 12:50:29 -------
r29970 - Enable the automatic resize feature by default in thinlinc
------- Comment #8 From cendio 2015-04-24 15:08:46 -------
Pans just fine now. Tested with Firefox on Android.