www.cendio.com
Bug 4864 - HTML client times out against solaris server
: HTML client times out against solaris server
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-10-23 14:08 by
Modified: 2014-04-01 16:04 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-10-23 14:08:38
The HTML client very rarely works against a Solaris machine because the
connection times out. Most likely caused by the fact that the SSL handshake is
horribly slow on Solaris. We already have bug 3858 for that matter, but we
should probably increase the timeouts in the HTML client.
------- Comment #1 From cendio 2014-02-06 16:01:58 -------
Completely removed the connection timeout in revision 28383, verified that it
works against a Solaris server.
------- Comment #2 From cendio 2014-03-20 12:51:03 -------
Doesn't seem to time out anymore, but after login and before NoVNC starts I get
the "Your session has ended" message/"Go to login page". Waiting 10 seconds or
so, the session starts.
------- Comment #3 From cendio 2014-03-26 09:31:48 -------
(In reply to comment #2)
> Doesn't seem to time out anymore, but after login and before NoVNC starts I get
> the "Your session has ended" message/"Go to login page". Waiting 10 seconds or
> so, the session starts.

The code that cause this behavior was committed for bug 4721, reopening that
instead.
------- Comment #4 From cendio 2014-03-27 16:30:07 -------
Haven't seen any timeouts when testing the Solaris server with builds
4293-4304.