www.cendio.com
Bug 4866 - Traceback in tlwebaccess
: Traceback in tlwebaccess
Status: CLOSED FIXED
: ThinLinc
Web Access
: 4.1.0
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-10-24 08:11 by
Modified: 2014-04-01 16:05 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-10-24 08:11:05
2013-10-23 14:05:59 INFO tlwebaccess[21856]: "GET /websocket/salefsi0/2
HTTP/1.1" 101 -
2013-10-23 14:05:59 INFO tlwebaccess[21856]: : SSL/TLS (wss://) WebSocket
connection
2013-10-23 14:05:59 INFO tlwebaccess[21856]: : Version hybi-13, base64: 'False'
2013-10-23 14:05:59 INFO tlwebaccess[21856]: : Path: '/websocket/salefsi0/2'
2013-10-23 14:05:59 INFO tlwebaccess[21856]: connecting to: localhost:5902
----------------------------------------
Exception happened during processing of request from ('', '', True)
Traceback (most recent call last):
  File "/usr/lib64/python2.6/SocketServer.py", line 537, in process_request
    self.finish_request(request, client_address)
  File "/opt/thinlinc/sbin/tlwebaccess", line 527, in finish_request
    raise O00OOOoOoo0O
error: [Errno 107] Transport endpoint is not connected
------- Comment #1 From cendio 2014-02-18 17:08:23 -------
*** Bug 4995 has been marked as a duplicate of this bug. ***
------- Comment #2 From cendio 2014-02-18 17:10:24 -------
I got this when i pressed quit in the ThinLinc Profile Chooser on the first
screen, i.e before clicking "Forward". It happens 9 out of 10 times when I do
this.
------- Comment #3 From cendio 2014-02-19 17:55:21 -------
Fixed in 28470.
------- Comment #4 From cendio 2014-02-20 12:40:40 -------
> Fixed in 28470.

The actual problem did in fact occur earlier in the process. The full traceback
is as follows:

Traceback (most recent call last):
  File "/opt/thinlinc/sbin/tlwebaccess", line 436, in new_websocket_client
    self.do_proxy(vncserver)
  File "/opt/thinlinc/sbin/tlwebaccess", line 487, in do_proxy
    data = server.recv(self.buffer_size)
error: [Errno 104] Connection reset by peer
----------------------------------------
Exception happened during processing of request from ('', '', True)
Traceback (most recent call last):
  File "/usr/lib64/python2.7/SocketServer.py", line 557, in process_request
    self.finish_request(request, client_address)
  File "/opt/thinlinc/sbin/tlwebaccess", line 528, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/opt/thinlinc/modules/thinlinc/websocket.py", line 97, in __init__
    SimpleHTTPRequestHandler.__init__(self, req, addr, server)
  File "/usr/lib64/python2.7/SocketServer.py", line 638, in __init__
    self.handle()
  File "/opt/thinlinc/sbin/tlwebaccess", line 349, in handle
    thinlinc.websocket.WebSocketRequestHandler.handle(self)
  File "/opt/thinlinc/modules/thinlinc/websocket.py", line 499, in handle
    SimpleHTTPRequestHandler.handle(self)
  File "/usr/lib64/python2.7/BaseHTTPServer.py", line 340, in handle
    self.handle_one_request()
  File "/usr/lib64/python2.7/BaseHTTPServer.py", line 328, in
handle_one_request
    method()
  File "/opt/thinlinc/sbin/tlwebaccess", line 189, in do_GET
    if not self.handle_websocket():
  File "/opt/thinlinc/sbin/tlwebaccess", line 207, in handle_websocket
    return thinlinc.websocket.WebSocketRequestHandler.handle_websocket(self)
  File "/opt/thinlinc/modules/thinlinc/websocket.py", line 459, in
handle_websocket
    self.new_websocket_client()
  File "/opt/thinlinc/sbin/tlwebaccess", line 441, in new_websocket_client
    vncserver.shutdown(socket.SHUT_RDWR)
  File "/usr/lib64/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 107] Transport endpoint is not connected
----------------------------------------

Correct handling of this bug was committed in r28478. A fix for logging the
whole traceback was also included, r28479.
------- Comment #5 From cendio 2014-03-03 17:13:13 -------
Fix updated in revision 28551.
------- Comment #6 From cendio 2014-03-19 13:00:52 -------
Couldn't reproduce the issue tested using build 4290. Review code and it looks
all good.