www.cendio.com
Bug 4895 - HTML5 client authentication can fail on busy system
: HTML5 client authentication can fail on busy system
Status: CLOSED FIXED
: ThinLinc
Web Access
: 4.1.1
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-11-12 13:03 by
Modified: 2014-04-01 16:09 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-11-12 13:03:59
When bug 4832 was fixed, a bug was introduced which makes the authentication
fail if the system is somewhat busy. It's a race condition between the
tlwebaccess process and the pamtester helper binary.
------- Comment #2 From cendio 2013-11-12 15:07:44 -------
I believe I've managed to fix this in 28132. Keeping bug open until next nighty
build, which will be installed on demo systems and possible published as
hotfix. 

Extensive testing is required. In addition to all test cases mentioned on bug
4832
and bug 4132, we also need to test on a loaded system. This bug was discovered
while running /opt/demosyst/libexec/setquotas.py on eudemo, so that might be a
good test case.
------- Comment #3 From cendio 2013-11-20 08:57:49 -------
Hotfix uploaded to http://www.cendio.com/downloads/updates/b4895/. Also
installed on both demo servers.
------- Comment #4 From cendio 2014-03-18 07:06:53 -------
Tested using build 4289:

Created a script to create a heavy load (disk i/o, tty i/o and cpu) on a
virtual machine. Couldn't reproduce the problem. All test logins got
authenticated correctly. 10 seconds from hitting the login button to get to the
actual desktop.