www.cendio.com
Bug 4904 - ThinLincClientVerifier incorrectly claims client is installed on Linux
: ThinLincClientVerifier incorrectly claims client is installed on Linux
Status: CLOSED FIXED
: ThinLinc
Client platforms
: 4.1.0
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-11-19 14:56 by
Modified: 2014-04-14 14:49 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-11-19 14:56:29
On Ubuntu 12.04, the ThinLincClientVerifier says the client is OK, and enables
the Continue button, even though the client is not installed.
------- Comment #1 From cendio 2013-11-19 16:00:16 -------
Our applet executes:

xdg-mime query default application/vnd.cendio.thinlinc.clientconf

However, xdg-mime returns no output and exits with return code zero, which we
interpret as "success". I believe this is wrong. The documentation is not fully
clear on the return code, but in case of success the name of the .desktop file
should be returned. Thus, it should be safer to verify this. 

Also note that on least my system (CentOS 6), xdg-mime seems to be very
unstable. Right now, it does not return anything when the client is installed,
but after UNINSTALLING it, it returns the .desktop file...
------- Comment #2 From cendio 2013-11-19 16:03:52 -------
(In reply to comment #1)

> Also note that on least my system (CentOS 6), xdg-mime seems to be very
> unstable. Right now, it does not return anything when the client is installed,
> but after UNINSTALLING it, it returns the .desktop file...

Probably due to https://bugs.freedesktop.org/show_bug.cgi?id=31629. We should
ship an updated version of xdg-mime. However, since the system version will
have precedence, this will not change much in practice.
------- Comment #3 From cendio 2013-11-19 16:35:56 -------
(In reply to comment #2)
> (In reply to comment #1)
> 
> > Also note that on least my system (CentOS 6), xdg-mime seems to be very
> > unstable. Right now, it does not return anything when the client is installed,
> > but after UNINSTALLING it, it returns the .desktop file...
> 
> Probably due to https://bugs.freedesktop.org/show_bug.cgi?id=31629. We should
> ship an updated version of xdg-mime. However, since the system version will
> have precedence, this will not change much in practice.

New vendordrop in 28148.
------- Comment #4 From cendio 2013-11-20 12:44:13 -------
(In reply to comment #1)
> Our applet executes:
> 
> xdg-mime query default application/vnd.cendio.thinlinc.clientconf
> 
> However, xdg-mime returns no output and exits with return code zero, which we
> interpret as "success". I believe this is wrong. The documentation is not fully
> clear on the return code, but in case of success the name of the .desktop file
> should be returned. Thus, it should be safer to verify this. 

Fixed in 28156, we are checking for at least one line of output instead.
------- Comment #5 From cendio 2013-12-02 12:42:12 -------
*** Bug 2850 has been marked as a duplicate of this bug. ***
------- Comment #6 From cendio 2013-12-02 12:43:10 -------
*** Bug 4456 has been marked as a duplicate of this bug. ***
------- Comment #7 From cendio 2014-04-14 14:49:05 -------
Verified functionality using build 4323, works as expected.