www.cendio.com
Bug 4941 - only show certificate download on mobile safari
: only show certificate download on mobile safari
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-12-12 13:07 by
Modified: 2014-04-02 08:59 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-12-12 13:07:02
This is a minimal effort version of bug 4863. Instead of going all out in
magical detection, we'll just make the current display conditional on the
browser being Safari on iOS.
------- Comment #1 From cendio 2014-02-10 16:01:08 -------
Fixed revision 28392.
------- Comment #2 From cendio 2014-02-11 10:04:09 -------
Fix updated in r28395.
------- Comment #3 From cendio 2014-02-14 12:34:56 -------
Updated again in revision 28431.
------- Comment #4 From cendio 2014-03-06 09:47:16 -------
Update for iOS's "web app" mode in r28562.
------- Comment #5 From cendio 2014-03-18 14:31:46 -------
Redirection page shows the link whatever browser i use.
------- Comment #6 From cendio 2014-03-18 14:38:48 -------
(In reply to comment #5)
> Redirection page shows the link whatever browser i use.

fixed in revision 28655.
------- Comment #7 From cendio 2014-03-19 12:22:07 -------
(In reply to comment #6)
> (In reply to comment #5)
> > Redirection page shows the link whatever browser i use.
> 
> fixed in revision 28655.

Tested using build 4290 and everything works fine. Reviewed additional commit
28655 which looks good.
------- Comment #8 From cendio 2014-03-20 07:34:52 -------
*** Bug 5029 has been marked as a duplicate of this bug. ***
------- Comment #9 From cendio 2014-03-20 07:36:24 -------
Traceback in related code when 'User-Agent' header not exists in request.

See duplicate in previous comment for more details.
------- Comment #10 From cendio 2014-03-20 08:02:41 -------
The download link is shown on android browser.
------- Comment #11 From cendio 2014-03-25 16:10:16 -------
(In reply to comment #9)
> Traceback in related code when 'User-Agent' header not exists in request.
> 
> See duplicate in previous comment for more details.

Fixed in revision 28712.

(In reply to comment #10)
> The download link is shown on android browser.

Fixed in revision 28711.
------- Comment #12 From cendio 2014-03-26 11:07:22 -------
(In reply to comment #11)
> (In reply to comment #9)
> > Traceback in related code when 'User-Agent' header not exists in request.
> > 
> > See duplicate in previous comment for more details.
> 
> Fixed in revision 28712.
> 
> (In reply to comment #10)
> > The download link is shown on android browser.
> 
> Fixed in revision 28711.

Verified with build 4303 tested using both android browser and iPad. Work as
expected.