www.cendio.com
Bug 5011 - Printer redirection seems to be broken with Windows 2012 R2
: Printer redirection seems to be broken with Windows 2012 R2
Status: CLOSED FIXED
: ThinLinc
rdesktop
: 4.1.1
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-03-05 10:54 by
Modified: 2014-05-15 08:43 (History)
Acceptance Criteria:


Attachments
Patch to always register rdpsnd channel. (1.67 KB, patch)
2014-03-06 07:27, Henrik Andersson
Details
Updated patch (2.23 KB, patch)
2014-03-06 11:29, Henrik Andersson
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-03-05 10:54:43
I couldn't even by specifying a printer driver get printer redirection to work.
------- Comment #1 From cendio 2014-03-05 15:36:01 -------
This actually does work, provided:

1) Sound is enabled ("-r sound:local:alsa" or whatever)
2) A valid printer driver is specified for the exported printer
("printer:thinlocal="MS Publisher Imagesetter"" for example - see bug #4362)

Have tested briefly against Windows 2012 and 2012R2 - printing to thinlocal
seems to work with thinlinc-rdesktop-4.1.1.
------- Comment #2 From cendio 2014-03-06 07:09:04 -------
This is intended behavior for 2012 and specs has been updated:

http://social.msdn.microsoft.com/Forums/en-US/75024a3d-458f-4ed9-b55d-7852d0113bd7/rdpbcgrpdf-2-minors-problems-with-server-2012
------- Comment #3 From cendio 2014-03-06 07:27:39 -------
Created an attachment (id=511) [details]
Patch to always register rdpsnd channel.

This patch ensures that the rdpsnd and rdpdr static channels always are
registered. Fixes both print and local drive redirection. Smartcard still have
some problems, but i see communication over pcsc..
------- Comment #4 From cendio 2014-03-06 11:29:53 -------
Created an attachment (id=512) [details]
Updated patch

This is a patch the more properly handles a rdpsnd tunnel, it announces but
only set capabilities to be alive if sound is enabled using -r sound argument.
------- Comment #5 From cendio 2014-03-06 12:44:25 -------
(In reply to comment #4)
> Created an attachment (id=512) [details] [details]
> Updated patch
> 
> This is a patch the more properly handles a rdpsnd tunnel, it announces but
> only set capabilities to be alive if sound is enabled using -r sound argument.

Commit upstream 1791.
------- Comment #6 From cendio 2014-03-06 13:19:20 -------
(In reply to comment #5)
> (In reply to comment #4)
> > Created an attachment (id=512) [details] [details] [details]
> > Updated patch
> > 
> > This is a patch the more properly handles a rdpsnd tunnel, it announces but
> > only set capabilities to be alive if sound is enabled using -r sound argument.
> 
> Commit upstream 1791.

Vendordrop in commit 28565.
------- Comment #7 From cendio 2014-03-07 09:49:44 -------
(In reply to comment #5)
> (In reply to comment #4)
> > Created an attachment (id=512) [details] [details] [details]
> > Updated patch
> > 
> > This is a patch the more properly handles a rdpsnd tunnel, it announces but
> > only set capabilities to be alive if sound is enabled using -r sound argument.
> 
> Commit upstream 1791.

Changes to audio and print/drive redirection has been tested against, Windows
2013r/2008r2/2012r2, Windows 8.1.
------- Comment #8 From cendio 2014-05-05 13:57:02 -------
Printer redirection tested on bug 4362. 

Sound now tested on 2003R2, 2008R2, and 2012R2, of course using
https://www.youtube.com/watch?v=moSFlvxnbgk . 

For Windows 2012R2, I was not able to get sound working until I did "net start
audiosrv" in a command shell as admin. But apparently, in the brave new Windows
world, this is how it should be...
------- Comment #9 From cendio 2014-05-13 16:10:19 -------
*** Bug 5134 has been marked as a duplicate of this bug. ***
------- Comment #10 From cendio 2014-05-13 16:11:25 -------
(In reply to comment #9)
> *** Bug 5134 has been marked as a duplicate of this bug. ***

Upstream commit 1796 fixes introduced issue reported oon bug #5134.
------- Comment #11 From cendio 2014-05-13 16:16:36 -------
(In reply to comment #10)
> (In reply to comment #9)
> > *** Bug 5134 has been marked as a duplicate of this bug. ***
> 
> Upstream commit 1796 fixes introduced issue reported oon bug #5134.

Vendordrop brought to ctc in commit 28974.
------- Comment #12 From cendio 2014-05-15 08:43:57 -------
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #9)
> > > *** Bug 5134 has been marked as a duplicate of this bug. ***
> > 
> > Upstream commit 1796 fixes introduced issue reported oon bug #5134.
> 
> Vendordrop brought to ctc in commit 28974.

recording works now (although not very good on my workstation, but that's
another bug).