www.cendio.com
Bug 5017 - Include Italian translation
: Include Italian translation
Status: CLOSED FIXED
: ThinLinc
Other
: trunk
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-03-10 10:46 by
Modified: 2014-05-16 10:07 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-03-10 10:46:36
Include an Italian translation. From Wikipedia: 

"According to the Bologna statistics of the European Union, Italian is spoken
as a native language by 59 million people in the EU (13% of the EU population),
mainly in Italy, and as a second language by 14 million (3%).[2] Including the
Italian speakers in non-EU European countries (such as Switzerland and Albania)
and on other continents, the total number of speakers is more than 85 million."
------- Comment #2 From cendio 2014-03-20 11:11:24 -------
Fixed in r28685.
------- Comment #3 From cendio 2014-04-14 09:51:08 -------
Tested using client build 4323 and found one string not fitting in UI under
options->optimization tab.

1107- msgid "Custom compression level:"
1108--msgstr ""
1109:+msgstr "Livello di compressione personalizzato:"
------- Comment #4 From cendio 2014-04-14 14:25:36 -------
(In reply to comment #3)
> Tested using client build 4323 and found one string not fitting in UI under
> options->optimization tab.
> 
> 1107- msgid "Custom compression level:"
> 1108--msgstr ""
> 1109:+msgstr "Livello di compressione personalizzato:"

r28842.
------- Comment #5 From cendio 2014-04-14 14:55:12 -------
Verified using client build 4323 and post build including r28842. Looks good.
------- Comment #6 From cendio 2014-05-07 16:44:20 -------
Issues found using the tool in bug 5127. Most of these are simply mismatching
number of newlines, but there is at least one place where there is a format
specifier mismatch.



/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (4): Check if you want an existing session to be
ended when logging in.

Not saved since you probably want this
just on rare occasions.
 - msgstr (2): Seleziona se desideri terminare una sessione esistente
all'accesso.

Impostazione non salvata siccome probabilmente desideri effettuare questa
operazione solo raramente.

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (1): Check if you want sound to be sent
from server to your terminal
 - msgstr (0): Seleziona se desideri trasmettere il suono dal server al
terminale

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (1): Check if you want the session in full
screen mode instead of in a window
 - msgstr (0): Seleziona se desideri la sessione in modalità schermo intero
anziché in una finestra

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (2): Enter a comma separated list of certificate issuer attributes
used when matching filter.
Example: cn=Telia, o=TeliaSonera AB
 - msgstr (1): Inserisci un elenco con valori delimitati da virgole di
attributi dell'autorità di certificazione utilizzati durante la corrispondenza
del filtro. 
Esempio: cn=Telia, o=TeliaSonera AB

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (7): The server's host key is not cached in the registry. You
have no guarantee that the server is the computer you
think it is.

The key fingerprint for "%s" is:
%s

If you trust this host, click Continue. Otherwise, click Abort.
 - msgstr (5): La chiave dell'host del server non è nella memoria cache del
registro. Non hai alcuna garanzia che il server sia il computer che pensi.

L'impronta digitale della chiave per "%s" è:
%s

Se ti fidi di questo host, fai clic su Continua. Altrimenti, fai clic su
Abbandona.

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (3): There was an error performing the print request.
Check that there is a properly configured local printer.
Complete information about the error can be found in the
ThinLinc client log file.
 - msgstr (2): Si è verificato un errore durante l'esecuzione della richiesta
di stampa.
Verifica che sia presente una stampante locale correttamente configurata.
È possibile reperire informazioni complete sull'errore nel file di registro del
client ThinLinc.

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (4): ThinLinc Client %d-bit v%s (%s)
%s
Copyright (C) 1999-2013 TigerVNC Team and many others
See included EULA.txt for licensing details.
See http://www.cendio.com for information on ThinLinc.
 - msgstr (3): ThinLinc Client %d-bit v%s (%s) %s 
Copyright (C) 1999-2013 TigerVNC Team e molti altri
Consultare EULA.txt per i dettagli della licenza. 
Visitare http://www.cendio.com per informazioni su ThinLinc.

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (6): Usage: tlcontrol [options]

Options:
   -h | -?         display this help summary
   -s              enable screen settings tab
   -o              set override-redirect flag

 - msgstr (5): Utilizzo: tlcontrol [opzioni]  

Opzioni: -h | -? visualizza questo riepilogo di aiuto 
-s abilita scheda impostazioni schermo 
-o imposta flag override/reindirizzamento


/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (4): Usage: wyseconfig [options]

Options:
   -h, --help         display this help summary

 - msgstr (3): Utilizzo: wyseconfig [opzioni]  

Opzioni: -h, --aiuta a visualizzare questo riepilogo di aiuto


/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (11): WARNING - POTENTIAL SECURITY BREACH!
The server's host key does not match the one ThinLinc has
cached in the registry. This means that either the
server administrator has changed the host key, or you
have actually connected to another computer pretending
to be the server.

The new key fingerprint for "%s" is:
%s

If you were expecting this change and trust the new key,
click Continue. Otherwise, click Abort.
 - msgstr (6): ATTENZIONE - POTENZIALE VIOLAZIONE DI SICUREZZA! 
La chiave dell'host del server non corrisponde a quella presente nella chace
del registro ThinLinc. Ciò significa che l'amministratore del server ha
modificato la chiave dell'host, oppure ti sei connesso a un altro computer
fingendo di essere il server.  

La nuova impronta digitale della chiave di "%s" è: 
%s  

Se ti aspettavi questa modifica e ti fidi della nuova chiave, fai clic su
Continua. Altrimenti, fai clic su Abbandona.

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (11): WARNING - POTENTIAL SECURITY BREACH!
The server's host key does not match the one ThinLinc has
cached in the registry. This means that either the
server administrator has changed the host key, or you
have actually connected to another computer pretending
to be the server.

The new key fingerprint for "%s" is:
%s

Your ThinLinc client is configured to NOT allow connecting
in this situation.
 - msgstr (6): ATTENZIONE - POTENZIALE VIOLAZIONE DI SICUREZZA! 
La chiave dell'host del server non corrisponde a quella presente nella chace
del registro ThinLinc. Ciò significa che l'amministratore del server ha
modificato la chiave dell'host, oppure ti sei connesso a un altro computer
fingendo di essere il server.  

La nuova impronta digitale della chiave di "%s" è: 
%s  

Il tuo client ThinLinc è configurato in modo da NON consentire la connessione
in questa situazione.

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (9): WARNING - SECURITY BREACH
The host key received from the server for the agent you are
about to connect to and the host key reported by the agent
itself doesn't concur.

This almost certainly means there are a third party trying to listen
to the communication between you and the server

Contact your systems administrator about this problem!
You will not be connected to the system at this time
 - msgstr (6): ATTENZIONE - VIOLAZIONE DI SICUREZZA 
La chiave dell'host ricevuta dal server per l'agente al quale stai per
connetterti e la chiave dell'host segnalata dall'agente stesso non
corrispondono.

Quasi sicuramente questo significa che è presente un soggetto terzo che sta
tentando di ascoltare la comunicazione tra te e il server.

Contatta il tuo amministratore di sistema in merito a questo problema!
Non verrai connesso al sistema in questa occasione

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (4): You are running the ThinLinc client as root, and have 
activated export of local drives. This means that the user "%s" 
on the ThinLinc server will have full access, as root, to all exported 
files. Do not continue if you do not trust the ThinLinc server. 

 - msgstr (1): Stai eseguendo il client ThinLinc come principale e hai attivato
l'esportazione delle unità locali. Ciò significa che l'utente "%s" sul server
ThinLinc avrà l'accesso completo, come server principale, a tutti i file
esportati. Non continuare se non ti fidi del server ThinLinc...


/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (3): You have exported the serial device "%s", but you do not have
read/write permissions to the device file.
This means serial device redirection will not work.

 - msgstr (2): Hai esportato il dispositivo seriale "%s", ma non disponi dei
permessi di lettura/scrittura sul file del dispositivo. 
Ciò significa che il reindirizzamento del dispositivo seriale non funzionerà.


/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (2): You need to change your password now
Changing password for %s
(current) NT password:
 - msgstr (1): Devi modificare la password ora
Modifica della password per 

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '\n':
 - msgid (1): Your Xserver do not support the XFree86-Misc extention,
or XKB.  Keyboard settings will be unavailable.
 - msgstr (0): Il tuo Xserver non supporta l'estensione XFree86-Misc o XKB. Le
impostazioni della tastiera non saranno disponibili.

/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching number of '%':
 - msgid (1): You need to change your password now
Changing password for %s
(current) NT password:
 - msgstr (0): Devi modificare la password ora
Modifica della password per 
/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching ending punctuation:
 - msgid: Advanced>>
 - msgstr: Avanzate<<
/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching ending punctuation:
 - msgid: Device:
 - msgstr: Dispositivo...
/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching ending punctuation:
 - msgid: Misc.
 - msgstr: Varie
/opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
Mismatching ending punctuation:
 - msgid: You need to change your password now
Changing password for %s
(current) NT password:
 - msgstr: Devi modificare la password ora
Modifica della password per
------- Comment #7 From cendio 2014-05-08 08:21:37 -------
(In reply to comment #6)
> Issues found using the tool in bug 5127. Most of these are simply mismatching
> number of newlines, but there is at least one place where there is a format
> specifier mismatch.
> 
> 
> 
> /opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
> Mismatching number of '\n':

This might be valid. The translations are of different lengths, so more or less
line breaks can be required in the translated string than in the original one.
So not necessarily an error. In any case, let's leave all of these for bug
5127. 


> /opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
> Mismatching number of '%':
>  - msgid (1): You need to change your password now
> Changing password for %s
> (current) NT password:
>  - msgstr (0): Devi modificare la password ora
> Modifica della password per 

This translation is indeed invalid, removed now. Will be re-translated in next
release. 


> /opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
> Mismatching ending punctuation:
>  - msgid: Advanced>>
>  - msgstr: Avanzate<<
> /opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
> Mismatching ending punctuation:
>  - msgid: Device:
>  - msgstr: Dispositivo...

Fixed. 


> /opt/thinlinc/lib/tlclient/locale/it/LC_MESSAGES/tlclient.mo: ERROR:
> Mismatching ending punctuation:
>  - msgid: Misc.
>  - msgstr: Varie

This should be correct: "Misc." is an abbreviation for "Miscellaneous".
"Varie", on the other hand, is not an abbreviation. I guess we could add
"Misc." to a whitelist.
------- Comment #8 From cendio 2014-05-09 14:09:59 -------
*** Bug 5121 has been marked as a duplicate of this bug. ***
------- Comment #9 From cendio 2014-05-09 14:12:25 -------
Updates to this bug has been made on a (now marked as) duplicate bug (bug
5121).

(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #0)
> > 
> > > -description[it]=È stato avviato un ambiente bare bone con un solo terminale
> > > grafico.\nL'utilizzo è previsto solo per debugging e test.
> > > +description[it]=È stato avviato un ambiente bare bone con un solo terminale
> > > grafico.
> > > +L'utilizzo è previsto solo per debugging e test.
> > > 
> > > What is not visible here is that the \n has been replaced by a Windows style
> > > line break (\r\n). After this, neither the Web Admin Gui nor the profile
> > > chooser can be used. 
> > 
> > The problem is actually worse: The corruption happens also if you simply
> > include a line break in any Description input text field.
> 
> Moved to bug 5123. For this release, we will just fix the Italian translation.
> Fixed in 28939.
------- Comment #10 From cendio 2014-05-09 14:52:13 -------
(In reply to comment #9)
> Updates to this bug has been made on a (now marked as) duplicate bug (bug
> 5121).
> 
> (In reply to comment #3)
> > (In reply to comment #2)
> > > (In reply to comment #0)
> > > 
> > > > -description[it]=È stato avviato un ambiente bare bone con un solo terminale
> > > > grafico.\nL'utilizzo è previsto solo per debugging e test.
> > > > +description[it]=È stato avviato un ambiente bare bone con un solo terminale
> > > > grafico.
> > > > +L'utilizzo è previsto solo per debugging e test.
> > > > 
> > > > What is not visible here is that the \n has been replaced by a Windows style
> > > > line break (\r\n). After this, neither the Web Admin Gui nor the profile
> > > > chooser can be used. 
> > > 
> > > The problem is actually worse: The corruption happens also if you simply
> > > include a line break in any Description input text field.
> > 
> > Moved to bug 5123. For this release, we will just fix the Italian translation.
> > Fixed in 28939.

This works fine with build 4349.

(In reply to comment #7)

Changes in this commit looks good.
------- Comment #11 From cendio 2014-05-14 11:13:00 -------
ThinLinc 4.2.0 installer (Windows platform) shows a spanish string even if
local lang is english, issue verified on both Win7/8 and 4.1.1 installer does
not suffer from this problem.
------- Comment #12 From cendio 2014-05-14 17:02:56 -------
(In reply to comment #11)
> ThinLinc 4.2.0 installer (Windows platform) shows a spanish string even if
> local lang is english, issue verified on both Win7/8 and 4.1.1 installer does
> not suffer from this problem.

r28977.

Windows installers apparently not tested by tester. Need to test:

 - Client installer
 - Customizer
 - Installer generated by customizer
------- Comment #13 From cendio 2014-05-16 10:07:27 -------
(In reply to comment #12)
> (In reply to comment #11)
> > ThinLinc 4.2.0 installer (Windows platform) shows a spanish string even if
> > local lang is english, issue verified on both Win7/8 and 4.1.1 installer does
> > not suffer from this problem.
> 
> r28977.
> 
> Windows installers apparently not tested by tester. Need to test:
> 
>  - Client installer
>  - Customizer
>  - Installer generated by customizer

Henrik reports that the rc3 installers works just fine.